7f3c01dce8acb05bc69138c306e8730005506dfb
[framework/uifw/e17-extra-config-modules.git] / packaging / e17-extra-private-modules.spec
1 Name:       e17-extra-private-modules
2 Summary:    The E17 Extra Private Modules The E17 extra private modules consists of modules made by SAMSUNG
3 Version:    0.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Samsung Proprietary License
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(enlightenment)
9 BuildRequires:  pkgconfig(utilX)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(dlog)
12
13 %description
14 The E17 Extra Private Modules  The E17 extra private modules consists of modules made by SAMSUNG.
15
16 %prep
17 %setup -q
18
19
20 %build
21
22 export CFLAGS+=" -Wall -g -fPIC -rdynamic"
23 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
24
25 %ifarch %{arm}
26 export CFLAGS+=" -D_ENV_ARM"
27 %endif
28
29
30 for FILE in config-slp
31 do 
32         (cd $FILE && ./autogen.sh && ./configure --prefix=/usr && make )
33 done
34
35
36 %install
37 rm -rf %{buildroot}
38
39 for FILE in config-slp
40 do 
41         (cd $FILE && make install DESTDIR=%{buildroot} )
42 done
43
44 find  %{buildroot}/usr/lib/enlightenment/modules -name *.la | xargs rm 
45
46 %files
47 %defattr(-,root,root,-)
48 %{_libdir}/enlightenment/modules/*/*/*.so
49 %{_libdir}/enlightenment/modules/config-slp/module.desktop
50