Add default Smack manifest for e17-extra-private-modules.spec
[framework/uifw/e17-extra-config-modules.git] / packaging / e17-extra-private-modules.spec
1 Name:       e17-extra-private-modules
2 Summary:    The E17 Extra Private Modules The E17 extra private modules consists of modules made by SAMSUNG
3 Version:    0.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Samsung Proprietary License
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: packaging/e17-extra-private-modules.manifest 
9 BuildRequires:  pkgconfig(enlightenment)
10 BuildRequires:  pkgconfig(utilX)
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(dlog)
13
14 %description
15 The E17 Extra Private Modules  The E17 extra private modules consists of modules made by SAMSUNG.
16
17 %prep
18 %setup -q
19
20
21 %build
22 cp %{SOURCE1001} .
23
24 export CFLAGS+=" -Wall -g -fPIC -rdynamic"
25 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
26
27 %ifarch %{arm}
28 export CFLAGS+=" -D_ENV_ARM"
29 %endif
30
31
32 for FILE in config-slp
33 do 
34         (cd $FILE && ./autogen.sh && ./configure --prefix=/usr && make )
35 done
36
37
38 %install
39 rm -rf %{buildroot}
40
41 for FILE in config-slp
42 do 
43         (cd $FILE && make install DESTDIR=%{buildroot} )
44 done
45
46 find  %{buildroot}/usr/lib/enlightenment/modules -name *.la | xargs rm 
47
48 %files
49 %manifest e17-extra-private-modules.manifest
50 %defattr(-,root,root,-)
51 %{_libdir}/enlightenment/modules/*/*/*.so
52 %{_libdir}/enlightenment/modules/config-slp/module.desktop
53