Packaging: update version to 0.5.9
[platform/core/uifw/e-tizen-testcase.git] / packaging / e-tizen-unittests.spec
1 %define USE_GCOV 0
2
3 Name: e-tizen-unittests
4 Version: 0.5.9
5 Release: 1
6 Summary: The test case runner for enlightenment
7 URL: http://www.enlightenment.org
8 Group: Graphics & UI Framework/Other
9 Source0: %{name}-%{version}.tar.gz
10 Source1001: e-tizen-unittests.manifest
11 License: BSD-2-Clause
12 BuildRequires: pkgconfig(enlightenment)
13 BuildRequires: pkgconfig(eldbus)
14 BuildRequires: pkgconfig(capi-ui-efl-util)
15 BuildRequires: pkgconfig(ecore-wl2)
16 BuildRequires: gettext
17 BuildRequires: pkgconfig(tizen-extension-client)
18 BuildRequires: pkgconfig(tizen-launch-client)
19 BuildRequires: pkgconfig(tzsh-screensaver-manager-service)
20 BuildRequires: pkgconfig(tzsh-screensaver-service)
21 BuildRequires: gtest-devel
22 BuildRequires: pkgconfig(edje)
23 BuildRequires: edje-tools
24
25 %description
26 This package is a test case runner for enlightenment.
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
34 export CXXFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DEFL_BETA_API_SUPPORT "
35 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
36 %if "%{USE_GCOV}" == "1"
37 export CXXFLAGS+=" -DTIZEN_TEST_GCOV "
38 %endif
39
40 %autogen
41 %configure --prefix=/usr
42 make %{?_smp_mflags}
43
44 %install
45 rm -rf %{buildroot}
46 %__mkdir_p %{buildroot}/usr/share/e_tizen_unittests/data/
47 %__cp -afr data/img/launchimg_splash.png  %{buildroot}/usr/share/e_tizen_unittests/data/
48
49 # install
50 make install DESTDIR=%{buildroot}
51
52 %files
53 %manifest %{name}.manifest
54 %defattr(-,root,root,-)
55 %attr(550,root,root) %{_bindir}/e_tizen_unittests
56 %license COPYING
57 %{_datadir}/e_tizen_unittests/data/