Packaging: update version to 0.4.3
[platform/core/uifw/e-mod-tizen-wm-policy.git] / packaging / e-mod-tizen-wm-policy.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       e-mod-tizen-wm-policy
5 Summary:    The Enlightenment WM Policy Module for Tizen
6 Version:    0.4.3
7 Release:    1
8 Group:      Graphics & UI Framework/Other
9 License:    BSD-2-Clause and Flora-1.1
10 Source0:    %{name}-%{version}.tar.bz2
11 BuildRequires: pkgconfig(enlightenment)
12 BuildRequires: pkgconfig(ttrace)
13 BuildRequires: pkgconfig(sensor)
14 BuildRequires: pkgconfig(vconf)
15 %if %{with x}
16 BuildRequires: pkgconfig(x11)
17 %endif
18 %if %{with wayland}
19 BuildRequires: pkgconfig(eina)
20 BuildRequires: pkgconfig(ecore)
21 BuildRequires: pkgconfig(edje)
22 %endif
23 BuildRequires: pkgconfig(capi-system-info)
24
25 %if 0%{?TZ_SYS_RO_SHARE:1}
26 # TZ_SYS_RO_SHARE is defined
27 %else
28 %global TZ_SYS_RO_SHARE /usr/share
29 %endif
30
31 %description
32 The Enlightenment WM Policy Module for Tizen
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38 export CFLAGS+=" -DE_LOGGING=2 -Werror-implicit-function-declaration"
39 %if %{with wayland}
40 %reconfigure \
41       --enable-wayland-only \
42       --enable-auto-rotation
43 %else
44 %reconfigure
45 %endif
46 make %{?_smp_mflags}
47
48 %install
49 # install
50 %make_install
51
52 %files
53 %defattr(-,root,root,-)
54 %{_libdir}/enlightenment/modules/e-mod-tizen-wm-policy
55 %license COPYING COPYING.Flora
56
57 %define _unpackaged_files_terminate_build 0