add null check
[platform/core/uifw/e-mod-tizen-wm-policy.git] / packaging / e-mod-tizen-wm-policy.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       e-mod-tizen-wm-policy
5 Summary:    The Enlightenment WM Policy Module for Tizen
6 Version:    0.5.7
7 Release:    1
8 Group:      Graphics & UI Framework/Other
9 License:    BSD-2-Clause and Flora-1.1
10 Source0:    %{name}-%{version}.tar.bz2
11 BuildRequires: pkgconfig(enlightenment)
12 BuildRequires: pkgconfig(ttrace)
13 BuildRequires: pkgconfig(sensor)
14 BuildRequires: pkgconfig(vconf)
15 %if %{with x}
16 BuildRequires: pkgconfig(x11)
17 %endif
18 %if %{with wayland}
19 BuildRequires: pkgconfig(eina)
20 BuildRequires: pkgconfig(ecore)
21 BuildRequires: pkgconfig(edje)
22 %endif
23 BuildRequires: pkgconfig(capi-system-info)
24 BuildRequires: pkgconfig(aul)
25 BuildRequires: pkgconfig(pkgmgr-info)
26 BuildRequires: pkgconfig(tizen-policy-ext-server)
27
28 %if 0%{?TZ_SYS_RO_SHARE:1}
29 # TZ_SYS_RO_SHARE is defined
30 %else
31 %global TZ_SYS_RO_SHARE /usr/share
32 %endif
33
34 %description
35 The Enlightenment WM Policy Module for Tizen
36
37 %prep
38 %setup -q -n %{name}-%{version}
39
40 %build
41 export CFLAGS+=" -DE_LOGGING=2 -Werror-implicit-function-declaration"
42 %if %{with wayland}
43 %reconfigure \
44       --enable-wayland-only \
45       --enable-auto-rotation
46 %else
47 %reconfigure
48 %endif
49 make %{?_smp_mflags}
50
51 %install
52 # install
53 %make_install
54
55 %files
56 %defattr(-,root,root,-)
57 %{_libdir}/enlightenment/modules/e-mod-tizen-wm-policy
58 %license COPYING COPYING.Flora
59
60 %define _unpackaged_files_terminate_build 0