19c165f535e8a6e2419fa5ba805d28bbb3d351c5
[platform/core/uifw/e-mod-tizen-rdp.git] / packaging / e-mod-tizen-rdp.spec
1 Name: e-mod-tizen-rdp
2 Version: 0.1.14
3 Release: 1
4 Summary: The enlightenment rdp module for Tizen
5 URL: http://www.enlightenment.org
6 Group: Graphics & UI Framework/Other
7 Source0: %{name}-%{version}.tar.gz
8 License: BSD-2-Clause and MIT
9
10 %ifarch %{arm}
11 %define LIBGOMP use
12 %endif
13
14 BuildRequires: pkgconfig(enlightenment)
15 BuildRequires: pkgconfig(dlog)
16 BuildRequires: pkgconfig(wayland-server)
17 BuildRequires: pkgconfig(libtbm)
18 BuildRequires: pkgconfig(freerdp2)
19 BuildRequires: pkgconfig(winpr2)
20 BuildRequires: pkgconfig(winpr-tools2)
21 BuildRequires: pkgconfig(pixman-1)
22 BuildRequires: pkgconfig(openssl1.1)
23 BuildRequires: libopenssl11
24 BuildRequires: libopenssl1.1-devel
25
26 %if "%{LIBGOMP}" == "use"
27 Requires:       libgomp
28 %endif
29
30 %description
31 This package is a enlightenment rdp module for Tizen.
32
33 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
34
35 %prep
36 %setup -q
37
38 %build
39
40 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
41 export CFLAGS+=" -Wall -Werror -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} "
42 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
43
44 %reconfigure --enable-wayland-only
45
46 make
47
48 %install
49 rm -rf %{buildroot}
50
51 # install
52 make install DESTDIR=%{buildroot}
53
54 # clear useless textual files
55 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
56
57 %files
58 %defattr(-,root,root,-)
59 %{_libdir}/enlightenment/modules/e-mod-tizen-rdp
60 %license COPYING LICENSE