Modify smack checking method.
[platform/core/uifw/e-mod-tizen-keyrouter.git] / packaging / e-mod-tizen-keyrouter.spec
1 Name: e-mod-tizen-keyrouter
2 Version: 0.1.37
3 Release: 1
4 Summary: The Enlightenment Keyrouter Module for Tizen
5 URL: http://www.enlightenment.org
6 Group: Graphics & UI Framework/Other
7 Source0: %{name}-%{version}.tar.gz
8 License: BSD-2-Clause
9 BuildRequires: pkgconfig(enlightenment)
10 BuildRequires:  gettext
11 BuildRequires:  pkgconfig(ttrace)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(tizen-extension-server)
14 BuildRequires:  pkgconfig(cynara-client)
15 BuildRequires:  pkgconfig(cynara-creds-socket)
16 BuildRequires:  pkgconfig(capi-system-device)
17 BuildRequires:  pkgconfig(libtzplatform-config)
18 BuildRequires:  pkgconfig(libsmack)
19
20 %description
21 This package is a the Enlightenment Keyrouter Module for Tizen.
22
23 %prep
24 %setup -q
25
26 %build
27
28 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
29 export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DE_LOGGING=1 "
30 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
31
32 %autogen
33 %configure --prefix=/usr \
34            --enable-wayland-only \
35            --enable-cynara \
36            TZ_SYS_RO_APP=%{TZ_SYS_RO_APP}
37
38 make
39
40 %install
41 rm -rf %{buildroot}
42
43 # install
44 make install DESTDIR=%{buildroot}
45
46 # clear useless textual files
47 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
48
49 %files
50 %defattr(-,root,root,-)
51 %license COPYING
52 %{_libdir}/enlightenment/modules/e-mod-tizen-keyrouter