618d9cfd2d3bd063b0ed2bd2aee88da0702bfa66
[platform/core/uifw/e-mod-tizen-keyrouter.git] / packaging / e-mod-tizen-keyrouter.spec
1 Name: e-mod-tizen-keyrouter
2 Version: 0.1.37
3 Release: 1
4 Summary: The Enlightenment Keyrouter Module for Tizen
5 URL: http://www.enlightenment.org
6 Group: Graphics & UI Framework/Other
7 Source0: %{name}-%{version}.tar.gz
8 License: BSD-2-Clause
9 BuildRequires: pkgconfig(enlightenment)
10 BuildRequires:  gettext
11 BuildRequires:  pkgconfig(ttrace)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(tizen-extension-server)
14 BuildRequires:  pkgconfig(cynara-client)
15 BuildRequires:  pkgconfig(cynara-creds-socket)
16 BuildRequires:  pkgconfig(capi-system-device)
17 BuildRequires:  pkgconfig(libtzplatform-config)
18
19 %description
20 This package is a the Enlightenment Keyrouter Module for Tizen.
21
22 %prep
23 %setup -q
24
25 %build
26
27 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
28 export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DE_LOGGING=1 "
29 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
30
31 %autogen
32 %configure --prefix=/usr \
33            --enable-wayland-only \
34            --enable-cynara \
35            TZ_SYS_RO_APP=%{TZ_SYS_RO_APP}
36
37 make
38
39 %install
40 rm -rf %{buildroot}
41
42 # install
43 make install DESTDIR=%{buildroot}
44
45 # clear useless textual files
46 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
47
48 %files
49 %defattr(-,root,root,-)
50 %license COPYING
51 %{_libdir}/enlightenment/modules/e-mod-tizen-keyrouter