package: version up to 0.2.4
[platform/core/uifw/e-mod-tizen-gesture.git] / packaging / e-mod-tizen-gesture.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name: e-mod-tizen-gesture
5 Version: 0.2.4
6 Release: 1
7 Summary: The Enlightenment Gesture Module for Tizen
8 URL: http://www.enlightenment.org
9 Group: Graphics & UI Framework/Other
10 Source0: %{name}-%{version}.tar.gz
11 License: BSD-2-Clause
12 BuildRequires:  pkgconfig(enlightenment)
13 BuildRequires:  gettext
14 BuildRequires:  pkgconfig(wayland-server)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(tzsh-server)
18
19 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
20
21 %description
22 This package is a the Enlightenment Gesture Module for Tizen.
23
24 %prep
25 %setup -q
26
27 %build
28
29 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
30 export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DE_LOGGING=1 "
31 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
32
33 %autogen
34 %configure --prefix=/usr \
35            --enable-wayland-only \
36 make
37
38 %install
39 rm -rf %{buildroot}
40
41 # install
42 make install DESTDIR=%{buildroot}
43
44 # clear useless textual files
45 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
46
47 %files
48 %defattr(-,root,root,-)
49 %license COPYING
50 %{_libdir}/enlightenment/modules/e-mod-tizen-gesture