52e9762244c79b84fa4edc0ace3a2861227ef020
[platform/core/uifw/e-mod-tizen-eom.git] / packaging / e-mod-tizen-eom.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name: e-mod-tizen-eom
5 Version: 0.1.1
6 Release: 1
7 Summary: The Enlightenment eom Module for Tizen
8 URL: http://www.enlightenment.org
9 Group: Graphics & UI Framework/Other
10 Source0: %{name}-%{version}.tar.gz
11 License: BSD-2-Clause
12 BuildRequires: pkgconfig(enlightenment)
13 BuildRequires:  gettext
14 %if %{with x}
15 BuildRequires:  pkgconfig(x11)
16 %endif
17 %if %{with wayland}
18 BuildRequires:  pkgconfig(wayland-server)
19 %endif
20 BuildRequires:  pkgconfig(dlog)
21 %if "%{?profile}" == "common"
22 %else
23 BuildRequires:  e-tizen-data
24 %endif
25 %description
26 This package is a the Enlightenment eom Module for Tizen.
27
28 %prep
29 %setup -q
30
31 %build
32
33 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
34 export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS}"
35 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
36
37 %autogen
38 %if %{with wayland}
39 %configure --prefix=/usr --enable-wayland-only
40 %else
41 %configure --prefix=/usr
42 %endif
43
44 make
45
46 %install
47 rm -rf %{buildroot}
48
49 # for license notification
50 mkdir -p %{buildroot}/usr/share/license
51 cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
52
53 # install
54 make install DESTDIR=%{buildroot}
55
56 # clear useless textual files
57 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
58
59 %files
60 %defattr(-,root,root,-)
61 %{_libdir}/enlightenment/modules/e-mod-tizen-eom
62 /usr/share/license/%{name}