Packaging: update version to 0.1.20
[platform/core/uifw/e-mod-tizen-effect.git] / packaging / e-mod-tizen-effect.spec
1 Name: e-mod-tizen-effect
2 Version: 0.1.20
3 Release: 1
4 Summary: The effect module for the enlightenment
5 URL: http://www.enlightenment.org
6 Group: Graphics & UI Framework/Other
7 Source0: %{name}-%{version}.tar.gz
8 License: BSD-2-Clause
9 BuildRequires: pkgconfig(enlightenment)
10 BuildRequires: pkgconfig(eina)
11 BuildRequires: pkgconfig(ecore)
12 BuildRequires: pkgconfig(edje)
13 BuildRequires:  gettext
14 BuildRequires:  edje-tools
15 BuildRequires:  pkgconfig(wayland-server)
16 BuildRequires:  pkgconfig(tizen-extension-server)
17 BuildRequires: pkgconfig(wayland-tbm-server)
18
19 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
20
21 %description
22 This package provides various window effect(animation)
23 as one module of enlightenment.
24
25 %prep
26 %setup -q
27
28 %build
29
30 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
31 export CFLAGS+=" -Wall -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DE_LOGGING=1"
32 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
33
34 %autogen
35 %configure --prefix=%{_prefix}
36 make
37
38 %install
39 rm -rf %{buildroot}
40
41 # for license notification
42 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
43 cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
44
45 # install
46 make install DESTDIR=%{buildroot}
47
48 # clear useless textual files
49 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
50
51
52 %files
53 %defattr(-,root,root,-)
54 %{_libdir}/enlightenment/modules/e-mod-tizen-effect
55 %{_datadir}/enlightenment/data/themes
56 %{TZ_SYS_RO_SHARE}/license/%{name}
57