8999c64363f183b1dbf1c24d6f4570984db561b0
[platform/core/uifw/e-mod-tizen-effect.git] / packaging / e-mod-tizen-effect.spec
1 Name: e-mod-tizen-effect
2 Version: 0.2.15
3 Release: 1
4 Summary: The effect module for the enlightenment
5 URL: http://www.enlightenment.org
6 Group: Graphics & UI Framework/Other
7 Source0: %{name}-%{version}.tar.gz
8 License: BSD-2-Clause
9 BuildRequires: pkgconfig(enlightenment)
10 BuildRequires: pkgconfig(eina)
11 BuildRequires: pkgconfig(ecore)
12 BuildRequires: pkgconfig(edje)
13 BuildRequires:  gettext
14 BuildRequires:  edje-tools
15 BuildRequires: pkgconfig(wayland-server)
16 BuildRequires: pkgconfig(tizen-extension-server)
17 BuildRequires: pkgconfig(wayland-tbm-server)
18 BuildRequires: pkgconfig(libtdm)
19
20 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
21
22 %description
23 This package provides various window effect(animation)
24 as one module of enlightenment.
25
26 %prep
27 %setup -q
28
29 %build
30
31 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
32 export CFLAGS+=" -Wall -Werror-implicit-function-declaration -g -fPIC -rdynamic ${GC_SECTIONS_FLAGS} -DE_LOGGING=2"
33 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
34
35 %autogen
36 %configure --prefix=%{_prefix}
37 make
38
39 %install
40 rm -rf %{buildroot}
41
42 # install
43 make install DESTDIR=%{buildroot}
44
45 # clear useless textual files
46 find  %{buildroot}%{_libdir}/enlightenment/modules/%{name} -name *.la | xargs rm
47
48
49 %files
50 %defattr(-,root,root,-)
51 %license COPYING
52 %{_libdir}/enlightenment/modules/e-mod-tizen-effect
53 %{_datadir}/enlightenment/data/themes
54