resetting manifest requested domain to floor
[platform/core/security/dukgenerator.git] / packaging / dukgenerator.spec
1 Name:           dukgenerator
2 Version:        1.0.0
3 Release:        7
4 License:        Apache-2.0
5 Summary:        Device Unique Key Library
6 Group:          Security/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     dukgenerator.manifest
9 BuildRequires:  cmake
10
11 BuildRequires:  pkgconfig(cryptsvc)
12 BuildRequires:  pkgconfig(openssl)
13
14 %description
15 Device Unique Key Library.
16
17 %package devel
18 Summary:        Device Unique Key Library
19 Group:          Development/Libraries
20 Requires:       %{name} = %{version}
21
22 %description devel
23 Device Unique Key Library (Development Files).
24
25 %prep
26 %setup -q
27 cp %{SOURCE1001} .
28
29 %build
30 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
31 %cmake . -DLIB_INSTALL_DIR:PATH=%{_libdir} -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DDESCRIPTION="%{summary}" -DBUILD_SHARED_LIBS:BOOL=OFF
32 make %{?_smp_mflags}
33
34
35 %install
36 make DESTDIR=%{?buildroot:%{buildroot}} INSTALL_ROOT=%{?buildroot:%{buildroot}} install
37 rm -f %{?buildroot:%{buildroot}}%{_infodir}/dir
38 find %{?buildroot:%{buildroot}} -regex ".*\\.la$" | xargs rm -f --
39
40 %files
41 %manifest %{name}.manifest
42 %license LICENSE.APLv2
43 %{_libdir}/*.a
44
45
46 %files devel
47 %manifest %{name}.manifest
48 %{_includedir}/*
49 %{_libdir}/pkgconfig/dukgenerator.pc