initial import
[platform/core/security/drm-service-core-intel.git] / packaging / drm-service-core-intel.spec
1 Name:       drm-service-core-intel
2 Summary:    The plugin library for installing drm-service-core-intel.so
3 Version:    0.1.0
4 Release:    0
5 Group:      TO_BE/FILLED_IN
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9
10 Provides: libdrm-service-core-intel.so.0
11
12 Requires(post): /sbin/ldconfig  
13 Requires(postun): /sbin/ldconfig
14
15 %description
16 The plugin library for installing drm-service-core-intel.so
17
18 %package devel
19 Summary:    The plugin library for drm-service-core-intel(Development)
20 Group:      TO_BE/FILLED_IN
21 Requires:   %{name} = %{version}-%{release}
22
23 %description devel
24 The plugin library for installing drm-service-core-intel.so and header files.
25
26 %prep
27 %setup -q
28
29 %build
30 %ifarch %{arm}
31 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=arm
32 %else
33 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=ix86
34 %endif
35 make
36 #make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40
41 %make_install
42
43 %post
44 /bin/rm -f /etc/ld.so.cache
45 /sbin/ldconfig
46
47 mkdir -p /opt/var/drm/inteldrm
48 chown 0:5000 /opt/var/drm/inteldrm
49 chmod 775 /opt/var/drm/inteldrm
50
51 ln -s -f %{_libdir}/libdrm-service-core-intel.so.0.1.0 %{_libdir}/libdrm-service-core-intel.so.0
52 ln -s -f %{_libdir}/libdrm-service-core-intel.so.0 %{_libdir}/libdrm-service-core-intel.so
53
54 %postun -p /sbin/ldconfig
55
56 %files
57 %defattr(-,root,root,-)
58 %{_libdir}/libdrm-service-core-intel.so*
59
60 %files devel
61 %defattr(-,root,root,-)
62 %{_includedir}/drm-intel/*.h
63 %{_libdir}/pkgconfig/drm-service-core-intel.pc
64