Fix rpmlint errors on groups and license in spec
[platform/core/security/drm-client.git] / packaging / drm-client.spec
1 Name:       drm-client
2 Summary:    DRM client Package
3 Version:    0.0.30
4 Release:    0
5 Group:      Security/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     drm-client.manifest
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  cmake
13
14 %description
15 DRM client library (Shared Object)
16
17
18 %package devel
19 Summary:    Development files for %{name}
20 Group:      Security/Development
21 Requires:   %{name} = %{version}-%{release}
22 %description devel
23 Development files for %{name}
24
25 %prep
26 %setup -q
27 cp %{SOURCE1001} .
28
29 %build
30 %cmake .
31
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37
38 %post -p /sbin/ldconfig
39
40 %postun -p /sbin/ldconfig
41
42 %files
43 %manifest %{name}.manifest
44 %defattr(-,root,root,-)
45 %{_libdir}/*.so.*
46
47 %files devel
48 %manifest %{name}.manifest
49 %defattr(-,root,root,-)
50 %{_includedir}/drm-client/*
51 %{_libdir}/*.so
52 %{_libdir}/pkgconfig/drm-client.pc
53
54 %clean
55 rm -rf CMakeCache.txt
56 rm -rf CMakeFiles
57 rm -rf cmake_install.cmake
58 rm -rf Makefile
59 rm -rf install_manifest.txt
60 rm -rf *.pc
61 rm -rf documentation.list
62
63 rm -rf libdrm-client.so libdrm-client.so.0 libdrm-client.so.0.0.1