Change getters to use methodCallForce
[platform/core/security/dpm-auth.git] / packaging / dpm-auth.spec
1 Name:    dpm-auth
2 Version: 1.0.1
3 Release: 0
4 License: Apache-2.0
5 Source0: %{name}-%{version}.tar.gz
6 Summary: Tizen Device Policy Manager Authentication Policy Module
7 Group:   Security/Other
8 BuildRequires: gcc
9 BuildRequires: cmake
10 BuildRequires: gettext-tools
11 BuildRequires: pkgconfig(klay)
12 BuildRequires: pkgconfig(dpm-pil)
13 BuildRequires: pkgconfig(auth-fw-admin)
14 BuildRequires: pkgconfig(capi-system-info)
15 BuildRequires: pkgconfig(capi-base-common)
16
17 %description
18 The dpm-auth package provides authentication policy module for device policy manager
19
20 %files
21 %manifest dpm-auth.manifest
22 %defattr(644,root,root,755)
23 %attr(755,root,root) %{_libdir}/dpm/plugins/auth
24 %attr(755,root,root) %{_libdir}/libdpm-auth.so.%{version}
25 %{_libdir}/libdpm-auth.so.0
26
27 %prep
28 %setup -q
29
30 %build
31 %{!?build_type:%define build_type "RELEASE"}
32
33 %if %{build_type} == "DEBUG" || %{build_type} == "PROFILING" || %{build_type} == "CCOV"
34         CFLAGS="$CFLAGS -Wp,-U_FORTIFY_SOURCE"
35         CXXFLAGS="$CXXFLAGS -Wp,-U_FORTIFY_SOURCE"
36 %endif
37
38 %cmake . -DVERSION=%{version} \
39          -DCMAKE_BUILD_TYPE=%{build_type} \
40          -DPLUGIN_INSTALL_DIR=%{_libdir}/dpm/plugins \
41          -DSCRIPT_INSTALL_DIR=%{_scriptdir} \
42          -DSYSTEMD_UNIT_INSTALL_DIR=%{_unitdir} \
43          -DDATA_INSTALL_DIR=%{TZ_SYS_DATA}/dpm \
44          -DDB_INSTALL_DIR=%{TZ_SYS_DB} \
45          -DRUN_INSTALL_DIR=%{TZ_SYS_RUN} \
46          -DAPP_INSTALL_PREFIX="%{TZ_SYS_RO_APP}" \
47          -DAPP_SHARE_PACKAGES_DIR="%{TZ_SYS_RO_PACKAGES}" \
48
49 make %{?jobs:-j%jobs}
50
51 %install
52 %make_install
53
54 %clean
55 rm -rf %{buildroot}
56
57 %post
58
59 %preun
60
61 %postun
62
63 ## Devel Package ##############################################################
64 %package -n libdpm-auth-devel
65 Summary: Libraries and header files for device policy client development
66 Group: Development/Libraries
67 Requires: device-policy-manager = %{version}-%{release}
68
69 %description -n libdpm-auth-devel
70 The libdpm-auth-devel package includes the libraries and header files necessary for
71 developing the DPM client program.
72
73 %files -n libdpm-auth-devel
74 %manifest dpm-auth.manifest
75 %defattr(644,root,root,755)
76 %{_libdir}/libdpm-auth.so
77 %{_libdir}/pkgconfig/dpm-auth.pc
78 %{_includedir}/dpm