tizen beta release
[framework/web/wrt-commons.git] / packaging / dpl.spec
1 Name:       dpl
2 Summary:    Design patterns library
3 Version:    0.1.57
4 Release:    1
5 Group:      System/Libraries
6 License:    TBD
7 Source0:    %{name}-%{version}.tar.bz2
8 Requires(post):  /sbin/ldconfig
9 Requires(postun):  /sbin/ldconfig
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(ecore)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(heynoti)
14 BuildRequires:  pkgconfig(appcore-efl)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(sqlite3)
17 BuildRequires:  pkgconfig(db-util)
18 BuildRequires:  pkgconfig(glib-2.0)
19 BuildRequires:  pkgconfig(dlog)
20 BuildRequires:  pkgconfig(zlib)
21 BuildRequires:  pkgconfig(libpcrecpp)
22 BuildRequires:  pkgconfig(icu-uc)
23
24 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
25
26 %description
27 Design patterns library is a collection of useful C++ utilities to easily develop window applications.
28
29 %package efl
30 Summary:    Design patterns library - EFL based
31 Group:      System/Libraries
32
33 %description efl
34 Design patterns library is a collection of useful C++ utilities to easily develop window applications.
35
36 %package efl-devel
37 Summary:    Design patterns library - EFL based developer files
38 Group:      Development/Libraries
39 Requires:   %{name}-efl = %{version}-%{release}
40
41 %description efl-devel
42 Design patterns library is a collection of useful C++ utilities to easily develop window applications. The most important part of library is full MVC support. It also supports event-based architecture, adds wrappers for many packages and provides many basic C++ utilities as RAII objects, singletons, and many other.
43
44 %prep
45 %setup -q -n %{name}-%{version}
46
47 %build
48
49 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
50         -DDPL_LOG=ON \
51         -DDISABLE_GTK=ON
52
53 # Call make instruction with smp support
54 make %{?jobs:-j%jobs}
55
56 # >> build post
57 # << build post
58 %install
59 rm -rf %{buildroot}
60 %make_install
61
62 %clean
63 rm -rf %{buildroot}
64
65 %post -p /sbin/ldconfig
66
67 %postun -p /sbin/ldconfig
68
69
70 %files efl
71 %defattr(-,root,root,-)
72 %{_libdir}/lib*-efl.so*
73 # << files
74
75 %files efl-devel
76 %defattr(-,root,root,-)
77 %{_includedir}/dpl-efl/*
78 %{_libdir}/pkgconfig/*-efl.pc
79