resetting manifest requested domain to floor
[platform/upstream/doxygen.git] / packaging / doxygen.spec
1 Name:           doxygen
2 Version:        1.8.2
3 Release:        1
4 License:        GPL-2.0+
5 Summary:        Automated C, C++, and Java Documentation Generator
6 Url:            http://www.stack.nl/~dimitri/doxygen/
7 Group:          Development/Tools
8 Source:         http://ftp.stack.nl/pub/users/dimitri/doxygen-%{version}.src.tar.gz
9 Source1001:     doxygen.manifest
10 BuildRequires:  bison
11 BuildRequires:  flex
12 BuildRequires:  gcc-c++
13 BuildRequires:  gettext-tools
14 %description
15 Doxygen is a documentation system for C, C++, Java, and IDL. It can
16 generate an online class browser (in HTML) and an offline reference
17 manual (in LaTeX) from a set of documented source files. The
18 documentation is extracted directly from the sources. Doxygen is
19 developed on a Linux platform, but it runs on most other UNIX flavors
20 as well. An executable for Windows 95/NT is also available.
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} .
25
26 %build
27 unset QTDIR
28 ./configure \
29    --prefix %{_prefix} \
30    --shared \
31    --release
32 make %{?_smp_mflags}
33
34 %install
35 %make_install
36
37 %docs_package
38
39 %files
40 %manifest %{name}.manifest
41 %defattr(-,root,root)
42 %attr(755,root,root) %{_bindir}/*
43