Bump to doxygen 1.9.2
[platform/upstream/doxygen.git] / packaging / doxygen.spec
1 Name:           doxygen
2 Version:        1.9.2
3 Release:        1
4 License:        GPL-2.0+
5 Summary:        Automated C, C++, and Java Documentation Generator
6 Url:            http://www.stack.nl/~dimitri/doxygen/
7 Group:          Development/Tools
8 Source:         http://ftp.stack.nl/pub/users/dimitri/doxygen-%{version}.src.tar.gz
9 Source1001:     doxygen.manifest
10 Source1002:     0001_static_library_build.patch
11
12
13 # BuildRequires:  bison
14 # BuildRequires:  flex
15 # BuildRequires:  gcc-c++
16 # BuildRequires:  gettext-tools
17
18 BuildRequires:  cmake
19 BuildRequires:  python3
20 BuildRequires:  flex
21 BuildRequires:  bison
22
23 %description
24 Doxygen is a documentation system for C, C++, Java, and IDL. It can
25 generate an online class browser (in HTML) and an offline reference
26 manual (in LaTeX) from a set of documented source files. The
27 documentation is extracted directly from the sources. Doxygen is
28 developed on a Linux platform, but it runs on most other UNIX flavors
29 as well. An executable for Windows 95/NT is also available.
30
31 %prep
32 %setup -q
33 cp %{SOURCE1001} .
34 %{__patch} -p1 < %{SOURCE1002}
35
36 %build
37 export CFLAGS+=" -fPIC"
38 export CXXFLAGS+=" -fPIC"
39 export LDFLAGS+=" -pie"
40 %{?ubsan:
41 /usr/bin/gcc-unforce-options
42 /usr/bin/gcc-force-options -fsanitize=undefined -fno-sanitize=vptr
43 }
44 mkdir build
45 pushd build
46 %{cmake} -G "Unix Makefiles" ../
47 make %{?_smp_mflags}
48 popd
49
50 %install
51 pushd build
52 %make_install
53 popd
54
55 %docs_package
56
57 %files
58 %manifest %{name}.manifest
59 %{_bindir}/*
60