release the pacakge
[profile/ivi/download-provider.git] / packaging / download-provider.spec
1
2 Name:       download-provider
3 Summary:    download the contents in background.
4 Version:        0.0.5
5 Release:    6
6 Group:      TO_BE/FILLED_IN
7 License:    TO_BE/FILLED_IN
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /usr/bin/sqlite3
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gobject-2.0)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(libsoup-2.4)
15 BuildRequires:  pkgconfig(xdgmime)
16 BuildRequires:  pkgconfig(vconf)
17 BuildRequires:  pkgconfig(db-util)
18 BuildRequires:  pkgconfig(sqlite3)
19 BuildRequires:  pkgconfig(bundle)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-network-connection)
22
23 %description
24 Description: download the contents in background
25
26 %package devel
27 Summary:    download-provider
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 Description: download the contents in background (developement files)
33
34 %prep
35 %setup -q
36
37 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38
39 %build
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
47 ln -s %{_sysconfdir}/rc.d/init.d/download-provider-service  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70download-provider-service
48 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
49 ln -s %{_sysconfdir}/rc.d/init.d/download-provider-service  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70download-provider-service
50
51 mkdir -p %{buildroot}/opt/data/download-provider
52
53 %post
54 mkdir -p /opt/dbspace/
55 if [ ! -f /opt/dbspace/.download-provider.db ];
56 then
57         sqlite3 /opt/dbspace/.download-provider.db 'PRAGMA journal_mode=PERSIST;
58         CREATE TABLE downloading (id INTEGER PRIMARY KEY AUTOINCREMENT, uniqueid INTEGER UNIQUE, packagename TEXT, notification INTEGER, installpath TEXT, filename TEXT, creationdate TEXT, retrycount INTEGER, state INTEGER, url TEXT, mimetype TEXT, etag TEXT, savedpath TEXT);'
59         sqlite3 /opt/dbspace/.download-provider.db 'PRAGMA journal_mode=PERSIST;
60         CREATE TABLE history (id INTEGER PRIMARY KEY AUTOINCREMENT, uniqueid INTEGER UNIQUE, packagename TEXT, filename TEXT, creationdate TEXT, state INTEGER, mimetype TEXT, savedpath TEXT);'
61 fi
62
63 %files
64 %defattr(-,root,root,-)
65 %dir /opt/data/download-provider
66 /opt/data/download-provider/*.png
67 %{_libdir}/libdownloadagent.so.0.0.1
68 %{_libdir}/libdownloadagent.so
69 %{_bindir}/download-provider
70 %{_sysconfdir}/rc.d/init.d/download-provider-service
71 %{_sysconfdir}/rc.d/rc3.d/S70download-provider-service
72 %{_sysconfdir}/rc.d/rc5.d/S70download-provider-service
73
74 %files devel
75 %defattr(-,root,root,-)
76 %{_libdir}/libdownloadagent.so.0.0.1
77 %{_libdir}/libdownloadagent.so
78 %{_bindir}/download-provider
79 %{_includedir}/download-provider/download-provider.h
80 %{_libdir}/pkgconfig/download-provider.pc
81
82 %changelog
83 * Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
84 - free slot after getting event from url-download
85 - fix INTEGER OVERFLOW
86
87 * Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
88 - initialize mutex for auto-redownloading
89 - support Pause/Resume with new connection
90 - fix the memory leak
91
92 * Mon Aug 27 2012 Kwangmin Bang <justine.bang@samsung.com>
93 - Change the ownership of downloaded file
94 - Add detached option when pthread is created
95 - fix the failure getting history info from database
96 - fix first timeout takes a long time
97 - fix wrong checking of network status
98 - fix the crash by double free
99 - divide log level
100 - Resolve prevent defects for agent module
101 - Resolve a bug to join domain in case of playready
102
103 * Tue Aug 23 2012 Kwangmin Bang <justine.bang@samsung.com>
104 - event thread does not deal in some state
105 - fix the lockup by mutex and the crash by invaild socket event
106
107 * Tue Aug 22 2012 Jungki Kwak <jungki.kwak@samsung.com>
108 - Fix the crash when use notification
109 - One thread model for socket
110 - Fix the defects found by prevent tool
111 - Remove mutex lock/unlock in case of invalid id
112 - Support the status of download in case of getting new connection with requestid
113 - Clear db and register notification when stopped the download
114 - Update notification function
115 - Enable to set the defined file name by user
116
117 * Tue Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
118 - Enable to use destination path
119 - Add to handle invalid id
120
121 * Tue Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
122 - Change socket close timing
123
124 * Mon Aug 13 2012 Kwangmin Bang <justine.bang@samsung.com>
125 - Disable default dlog in launching script.
126
127 * Tue Aug 09 2012 Jungki Kwak <jungki.kwak@samsung.com>
128 - The function to init dbus glib is removed
129
130 * Tue Aug 08 2012 Jungki Kwak <jungki.kwak@samsung.com>
131 - The function to init dbus glib is added for connection network CAPI
132
133 * Tue Aug 07 2012 Jungki Kwak <jungki.kwak@samsung.com>
134 - Change the name of temp direcoty.
135 - When add requestinfo to slot, save it to DB.
136
137 * Mon Aug 06 2012 Jungki Kwak <jungki.kwak@samsung.com>
138 - Initial version is updated.
139