release the pacakge
[profile/ivi/download-provider.git] / packaging / download-provider.spec
1
2 Name:       download-provider
3 Summary:    download the contents in background.
4 Version:        0.0.5
5 Release:    7
6 Group:      TO_BE/FILLED_IN
7 License:    TO_BE/FILLED_IN
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /usr/bin/sqlite3
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gobject-2.0)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(libsoup-2.4)
15 BuildRequires:  pkgconfig(xdgmime)
16 BuildRequires:  pkgconfig(vconf)
17 BuildRequires:  pkgconfig(db-util)
18 BuildRequires:  pkgconfig(sqlite3)
19 BuildRequires:  pkgconfig(bundle)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-network-connection)
22
23 %description
24 Description: download the contents in background
25
26 %package devel
27 Summary:    download-provider
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 Description: download the contents in background (developement files)
33
34 %prep
35 %setup -q
36
37 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38
39 %build
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
47 ln -s %{_sysconfdir}/rc.d/init.d/download-provider-service  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70download-provider-service
48 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
49 ln -s %{_sysconfdir}/rc.d/init.d/download-provider-service  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70download-provider-service
50
51 mkdir -p %{buildroot}/opt/data/download-provider
52
53 %post
54 mkdir -p /opt/dbspace/
55 if [ ! -f /opt/dbspace/.download-provider.db ];
56 then
57         sqlite3 /opt/dbspace/.download-provider.db 'PRAGMA journal_mode=PERSIST;
58         CREATE TABLE downloading (id INTEGER PRIMARY KEY AUTOINCREMENT, uniqueid INTEGER UNIQUE, packagename TEXT, notification INTEGER, installpath TEXT, filename TEXT, creationdate TEXT, retrycount INTEGER, state INTEGER, url TEXT, mimetype TEXT, etag TEXT, savedpath TEXT);'
59         sqlite3 /opt/dbspace/.download-provider.db 'PRAGMA journal_mode=PERSIST;
60         CREATE TABLE history (id INTEGER PRIMARY KEY AUTOINCREMENT, uniqueid INTEGER UNIQUE, packagename TEXT, filename TEXT, creationdate TEXT, state INTEGER, mimetype TEXT, savedpath TEXT);'
61 fi
62
63 %files
64 %defattr(-,root,root,-)
65 %dir /opt/data/download-provider
66 /opt/data/download-provider/*.png
67 %{_libdir}/libdownloadagent.so.0.0.1
68 %{_libdir}/libdownloadagent.so
69 %{_bindir}/download-provider
70 %{_sysconfdir}/rc.d/init.d/download-provider-service
71 %{_sysconfdir}/rc.d/rc3.d/S70download-provider-service
72 %{_sysconfdir}/rc.d/rc5.d/S70download-provider-service
73
74 %files devel
75 %defattr(-,root,root,-)
76 %{_libdir}/libdownloadagent.so.0.0.1
77 %{_libdir}/libdownloadagent.so
78 %{_bindir}/download-provider
79 %{_includedir}/download-provider/download-provider.h
80 %{_libdir}/pkgconfig/download-provider.pc
81
82 %changelog
83 * Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
84 - fix timeout error
85
86 * Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
87 - free slot after getting event from url-download
88 - fix INTEGER OVERFLOW
89
90 * Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
91 - initialize mutex for auto-redownloading
92 - support Pause/Resume with new connection
93 - fix the memory leak
94
95 * Mon Aug 27 2012 Kwangmin Bang <justine.bang@samsung.com>
96 - Change the ownership of downloaded file
97 - Add detached option when pthread is created
98 - fix the failure getting history info from database
99 - fix first timeout takes a long time
100 - fix wrong checking of network status
101 - fix the crash by double free
102 - divide log level
103 - Resolve prevent defects for agent module
104 - Resolve a bug to join domain in case of playready
105
106 * Tue Aug 23 2012 Kwangmin Bang <justine.bang@samsung.com>
107 - event thread does not deal in some state
108 - fix the lockup by mutex and the crash by invaild socket event
109
110 * Tue Aug 22 2012 Jungki Kwak <jungki.kwak@samsung.com>
111 - Fix the crash when use notification
112 - One thread model for socket
113 - Fix the defects found by prevent tool
114 - Remove mutex lock/unlock in case of invalid id
115 - Support the status of download in case of getting new connection with requestid
116 - Clear db and register notification when stopped the download
117 - Update notification function
118 - Enable to set the defined file name by user
119
120 * Tue Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
121 - Enable to use destination path
122 - Add to handle invalid id
123
124 * Tue Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
125 - Change socket close timing
126
127 * Mon Aug 13 2012 Kwangmin Bang <justine.bang@samsung.com>
128 - Disable default dlog in launching script.
129
130 * Tue Aug 09 2012 Jungki Kwak <jungki.kwak@samsung.com>
131 - The function to init dbus glib is removed
132
133 * Tue Aug 08 2012 Jungki Kwak <jungki.kwak@samsung.com>
134 - The function to init dbus glib is added for connection network CAPI
135
136 * Tue Aug 07 2012 Jungki Kwak <jungki.kwak@samsung.com>
137 - Change the name of temp direcoty.
138 - When add requestinfo to slot, save it to DB.
139
140 * Mon Aug 06 2012 Jungki Kwak <jungki.kwak@samsung.com>
141 - Initial version is updated.
142