49c1294a697d1bdcdf06028900b2768754defa75
[platform/framework/web/download-provider.git] / packaging / download-provider.spec
1 Name:       download-provider
2 Summary:    Download the contents in background
3 Version:    2.1.119
4 Release:    0
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): sqlite
9 Requires(post): connman
10 Requires: security-config
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(gobject-2.0)
14 BuildRequires:  pkgconfig(xdgmime)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(sqlite3)
17 BuildRequires:  pkgconfig(bundle)
18 BuildRequires:  pkgconfig(capi-base-common)
19 BuildRequires:  pkgconfig(capi-appfw-app-manager)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-network-connection)
22 BuildRequires:  pkgconfig(appsvc)
23 BuildRequires:  pkgconfig(libcurl)
24 BuildRequires:  pkgconfig(capi-content-mime-type)
25 BuildRequires:  gettext-devel
26 BuildRequires:  pkgconfig(libsystemd-daemon)
27 BuildRequires:  pkgconfig(capi-network-wifi-direct)
28 %if "%{?profile}" != "wearable"
29 BuildRequires:  pkgconfig(notification)
30 %endif
31 BuildRequires:  pkgconfig(storage)
32 BuildRequires:  pkgconfig(cynara-client)
33 BuildRequires:  pkgconfig(cynara-client-async)
34 BuildRequires:  pkgconfig(cynara-creds-socket)
35 BuildRequires:  pkgconfig(cynara-creds-dbus)
36 BuildRequires:  pkgconfig(tpkp-curl)
37 BuildRequires:  pkgconfig(libtzplatform-config)
38
39 %if 0%{?gtests:1}
40 BuildRequires:  pkgconfig(gmock)
41 %endif
42
43 %description
44 Description: Download the contents in background
45
46 %package devel
47 Summary:    download-provider
48 Group:      Development/Libraries
49 Requires:   %{name} = %{version}-%{release}
50
51 %description devel
52 Description: Download the contents in background (development files)
53
54 %prep
55 %setup -q
56
57 %define _data_install_path %{TZ_SYS_GLOBALUSER_DATA}/%{name}
58 %define _resource_install_path /usr/share/%{name}
59 %define _imagedir %{_resource_install_path}/images
60 %define _localedir %{_resource_install_path}/locales
61 %define _databasedir %{_data_install_path}/database
62 %define _database_client_dir %{_databasedir}/clients
63 %define _notifydir %{_data_install_path}/notify
64 %define _ipc_socket /tmp/.download-provider.sock
65 %define _logdump_script_dir %{TZ_SYS_ETC}/dump.d/module.d
66 %define _http_lib libcurl
67 %define _manifest_name %{name}.manifest
68 %if "%{?tizen_profile_name}" == "tv"
69 %define _ca_cert /opt/data/cert/vdca.pem
70 %define _ca_path /opt/data/cert/user/
71 %endif
72
73 %build
74 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
75 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
76 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
77
78 %if 0%{?gcov:1}
79 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
80 export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
81 export FFLAGS+=" -fprofile-arcs -ftest-coverage"
82 export LDFLAGS+=" -lgcov"
83 %endif
84
85 %cmake -DTZ_SYS_GLOBALUSER_DATA=%TZ_SYS_GLOBALUSER_DATA \
86         -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
87         -DBIN_INSTALL_DIR:PATH=%{_bindir} \
88         -DLIB_INSTALL_DIR:PATH=%{_libdir} \
89         -DLIB_AGENT_PATH="/usr/%{?_lib}/libdownloadagent2.so.0.1.0" \
90         -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
91         -DPKG_NAME=%{name} \
92         -DPKG_VERSION=%{version} \
93         -DPKG_RELEASE=%{release} \
94         -DIPC_SOCKET:PATH=%{_ipc_socket} \
95         -DPROVIDER_DIR:PATH=%{_data_install_path} \
96         -DNOTIFY_DIR:PATH=%{_notifydir} \
97         -DDATABASE_DIR:PATH=%{_databasedir} \
98         -DDATABASE_CLIENT_DIR:PATH=%{_database_client_dir} \
99         -DIMAGE_DIR:PATH=%{_imagedir} \
100         -DLOCALE_DIR:PATH=%{_localedir} \
101         -DSUPPORT_WIFI_DIRECT:BOOL=OFF \
102         -DSUPPORT_DOWNLOAD_BOOSTER:BOOL=OFF \
103 %if "%{?profile}" == "wearable"
104         -DSUPPORT_NOTIFICATION:BOOL=OFF \
105 %else
106         -DSUPPORT_NOTIFICATION:BOOL=ON \
107 %endif
108         -DSUPPORT_LOG_MESSAGE:BOOL=ON \
109         -DSUPPORT_OMA_DRM:BOOL=OFF \
110         -DSUPPORT_COMPANION_MODE:BOOL=OFF \
111         -DTIZEN_2_3_UX:BOOL=ON \
112 %if "%{?profile}" == "wearable"
113         -DSUPPORT_MULTILINGUAL:BOOL=ON \
114 %else
115         -DSUPPORT_MULTILINGUAL:BOOL=OFF \
116 %endif
117         -DCMAKE_LOG_DUMP_SCRIPT_DIR=%{_logdump_script_dir} \
118         -DHTTP_LIB=%{_http_lib} \
119 %if "%{?_lib}" == "lib64"
120         %{?_cmake_lib_suffix64} \
121 %endif
122         %{?_cmake_skip_rpath} \
123         -DBUILD_SHARED_LIBS:BOOL=ON \
124         -DBUILD_GTESTS=%{?gtests:1}%{!?gtests:0} \
125         -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0} \
126         -DSUPPORT_LARGE_FILE:BOOL=ON \
127 %if "%{?tizen_profile_name}" == "tv"
128         -DUSE_SSL_THREAD_LOCKING:BOOL=ON \
129         -DCA_CERT=%{_ca_cert} \
130         -DCA_PATH=%{_ca_path} \
131 %endif
132         .
133
134 make %{?jobs:-j%jobs}
135
136 %install
137 rm -rf %{buildroot}
138 %make_install
139 %if "%{?tizen_profile_name}" == "tv"
140 mkdir -p %{buildroot}/etc/notstrip/
141 install -m 644 packaging/download-provider.notstrip %{buildroot}/etc/notstrip/download-provider.notstrip
142 %endif
143
144 ## container_enable
145 mkdir -p %{buildroot}/etc/vasum/vsmzone.resource/
146 mv %{buildroot}/usr/share/download-provider/download-provider.res %{buildroot}/etc/vasum/vsmzone.resource/
147
148 mkdir -p %{buildroot}/lib/systemd/system/sockets.target.wants
149 ln -s ../download-provider.socket %{buildroot}/lib/systemd/system/sockets.target.wants/
150
151 %post
152 #make notify dir in post section for smack
153 mkdir %{TZ_SYS_GLOBALUSER_DATA}/download-provider
154 mkdir -p %{_notifydir}
155 chown -R web_fw:web_fw %{_notifydir}
156 chsmack -a 'System::Shared' %{_notifydir}
157 chsmack -t %{_notifydir}
158 mkdir -p --mode=0700 %{_databasedir}
159 chown -R web_fw:web_fw %{_databasedir}
160 chsmack -a 'System' %{_databasedir}
161 mkdir -p --mode=0700 %{_database_client_dir}
162 chsmack -a 'System' %{_database_client_dir}
163 chown -R web_fw:web_fw %{_database_client_dir}
164 chown -R web_fw:web_fw %{_data_install_path}
165
166 %files
167 %defattr(-,root,root,-)
168 %manifest %{_manifest_name}
169 %{_imagedir}/*.png
170 %{_localedir}/*/*/download-provider.mo
171 %{_libdir}/*.so.*
172 /lib/systemd/system/download-provider.service
173 /lib/systemd/system/download-provider.socket
174 /lib/systemd/system/sockets.target.wants/download-provider.socket
175 %{_bindir}/%{name}
176 %attr(0544,root,root) %{_logdump_script_dir}/dump-%{name}.sh
177 ## container_enable
178 %attr(0644,root,root) /etc/vasum/vsmzone.resource/download-provider.res
179 %if "%{?tizen_profile_name}" == "tv"
180 /etc/notstrip/download-provider.notstrip
181 %endif
182 %license LICENSE.APLv2
183
184 %files devel
185 %defattr(-,root,root,-)
186 %{_bindir}/%{name}
187 %{_libdir}/*.so
188 %{_libdir}/pkgconfig/download-provider.pc
189 %{_libdir}/pkgconfig/download-provider-interface.pc
190 %{_libdir}/pkgconfig/download-agent.pc
191 %{_includedir}/download-provider/download-provider.h
192 %{_includedir}/download-provider/download-provider-interface.h
193 %{_includedir}/download-provider/download-agent-interface.h
194
195 %if 0%{?gtests:1}
196 %{_bindir}/gtest*
197 %endif