Add managed launcher part
[platform/core/dotnet/launcher.git] / packaging / dotnet-launcher.spec
1 Name:       dotnet-launcher
2 Summary:    Launchpad plugin for dotnet apps
3 Version:    0.0.1
4 Release:    1
5 Group:      Application Framework/Application State Management
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(aul)
11 BuildRequires: pkgconfig(bundle)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(ecore)
14 BuildRequires: pkgconfig(launchpad)
15 BuildRequires: aul-devel
16 BuildRequires: corefx-managed-32b-ref
17 BuildRequires: mono-compiler
18 BuildRequires: mono-devel 
19 BuildRequires: csapi-tizen 
20 Requires: aul
21
22 Requires(post): /sbin/ldconfig
23 Requires(post): /usr/bin/systemctl
24 Requires(postun): /sbin/ldconfig
25 Requires(postun): /usr/bin/systemctl
26 Requires(preun): /usr/bin/systemctl
27
28 %define _loaderdir %{_prefix}/share/aul
29 %define _configdir /etc
30
31 %description
32 Launchpad plugin for launching dotnet apps
33
34 %prep
35 %setup -q
36
37 %build
38 %if 0%{?tizen_build_devel_mode}
39 %define _buildmode Debug
40 %else
41 %define _buildmode Release
42 %endif
43 cmake \
44         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
45         -DPACKAGE_NAME=%{name} \
46         -DBINDIR=%{_bindir} \
47         -DLOADERDIR=%{_loaderdir} \
48         -DCONFIGDIR=%{_configdir} \
49         -DCMAKE_BUILD_TYPE=%{_buildmode} \
50         -DVERSION=%{version} \
51         NativeLauncher
52
53 make %{?jobs:-j%jobs}
54
55 xbuild /p:Configuration=%{_buildmode} Tizen.Runtime/Tizen.Runtime.csproj
56
57 %install
58 rm -rf %{buildroot}
59 %make_install
60 install -p -m 644 Tizen.Runtime/bin/Tizen.Runtime.dll %{buildroot}%{_bindir}
61
62 %files
63 %manifest dotnet-launcher.manifest
64 %config /etc/dotnet-launcher.ini
65 %{_loaderdir}/dotnet.loader
66 %caps(cap_mac_admin,cap_setgid=ei) %{_bindir}/dotnet-launcher
67 %caps(cap_mac_admin,cap_setgid=ei) %{_bindir}/Tizen.Runtime.dll