Add Launcher and Waiter for dotnet-launcher
[platform/core/dotnet/launcher.git] / packaging / dotnet-launcher.spec
1 Name:       dotnet-launcher
2 Summary:    Launchpad plugin for dotnet apps
3 Version:    0.1.0
4 Release:    1
5 Group:      Application Framework/Daemons
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(aul)
11 BuildRequires: pkgconfig(bundle)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(ecore)
14 BuildRequires: pkgconfig(launchpad)
15 BuildRequires: aul-devel
16 Requires: aul
17
18 Requires(post): /sbin/ldconfig
19 Requires(post): /usr/bin/systemctl
20 Requires(postun): /sbin/ldconfig
21 Requires(postun): /usr/bin/systemctl
22 Requires(preun): /usr/bin/systemctl
23
24 %define _sys_bin %{TZ_SYS_BIN}
25 %define _sys_sbin %{TZ_SYS_SBIN}
26 %define _sys_share %{TZ_SYS_RO_SHARE}
27 %define _manifestdir %{TZ_SYS_RO_PACKAGES}
28 %define _loaderdir %{TZ_SYS_RO_SHARE}/aul
29
30 %description
31 Launchpad for dotnet apps
32
33 %prep
34 %setup -q
35
36 %build
37 cmake \
38         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
39         -DMANIFESTDIR=%{_manifestdir} \
40         -DPACKAGE_NAME=%{name} \
41         -DBINDIR=%{_bindir} \
42         -DLOADERDIR=%{_loaderdir} \
43         -DVERSION=%{version}
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50
51 %post
52
53 %files
54 %manifest dotnet-launchpad.manifest
55 %{_manifestdir}/%{name}.xml
56 %{_loaderdir}/dotnet.loader
57 %attr(0755,root,root) %{_bindir}/dotnet-loader
58 %caps(cap_mac_admin,cap_mac_override,cap_setgid=ei) %{_bindir}/dotnet-loader