619fd7edf61e383f4af715f612a0fa031719f363
[platform/core/multimedia/dfs-adaptation.git] / packaging / dfs_adaptation.spec
1 Name:        dfs-adaptation
2 Summary:     Adaptation of depth-from-stereo
3 Version:     0.0.1
4 Release:     0
5 Group:       Multimedia/Framework
6 License:     Apache-2.0
7 Source0:     %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(libtzplatform-config)
11
12 %description
13 Adaptaion of depth-from-stereo
14
15 %package devel
16 Summary:    Adaptaion of depth-from-stereo
17 Group:      Multimedia/Framework
18 Requires:   %{name} = %{version}-%{release}
19
20 %description devel
21 Adaptaion of depth-from-stereo (Dev)
22
23 %prep
24 %setup -q
25
26 %build
27 %if 0%{?sec_build_binary_debug_enable}
28 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
29 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
30 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
31 %endif
32
33 export CFLAGS+=" -DPATH_LIBDIR=\\\"%{_libdir}\\\" -DSYSCONFDIR=\\\"%{_hal_sysconfdir}\\\""
34 export CXXFLAGS+=" -DPATH_LIBDIR=\\\"%{_libdir}\\\" -DSYSCONFDIR=\\\"%{_hal_sysconfdir}\\\""
35
36 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
37 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_BIN=%TZ_SYS_BIN \
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43
44 %make_install
45
46 %post -p /sbin/ldconfig
47 %postun -p /sbin/ldconfig
48
49 %files
50 %manifest %{name}.manifest
51 %license LICENSE.APLv2
52 %{_libdir}/libdfs-*.so.*
53
54 %files devel
55 %{_includedir}/media/*.h
56 %{_libdir}/pkgconfig/dfs*.pc
57 %{_libdir}/libdfs-*.so