0f9c9c577a6ea7f4205e984f78548c71cdfe0240
[platform/adaptation/RPI3/device-manager-plugin-RPI3.git] / packaging / device-manager-plugin-rpi3.spec
1 Name:       device-manager-plugin-rpi3
2 Summary:    Device manager plugin rpi3
3 Version:    0.0.1
4 Release:    0
5 Group:      System/Hardware Adaptation
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(hwcommon)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(libudev)
16
17 %description
18 Device manager plugin Raspberry Pi 3
19
20 %prep
21 %setup -q
22 cp %{SOURCE1} .
23
24 %build
25 %cmake .
26
27 make %{?jobs:-j%jobs}
28
29 %install
30 %make_install
31
32 %post
33 /sbin/ldconfig
34
35 %postun
36 /sbin/ldconfig
37
38 %files
39 %{_libdir}/hw/*.so
40 %manifest %{name}.manifest
41 %license LICENSE