Add default Smack manifest for device-config-touch.spec
[profile/ivi/device-config-touch.git] / packaging / device-config-touch.spec
1 Name:           device-config-touch
2 Version:        1
3 Release:        1
4 Summary:        Device specific configurations for Touch
5 Group:          System/Hardware
6 License:        GPLv2+
7 Source0:        %{name}-%{version}.tar.bz2
8 Source1001: packaging/device-config-touch.manifest 
9 # >> gbp-patch-tags         # auto-added by gbp
10 # << gbp-patch-tags         # auto-added by gbp
11 BuildArch: noarch
12
13 %description
14 Device specific configurations for Touch.
15
16 %define touch_package(n:) \
17 %package %1\
18 Summary:        Touch configuration files for %1\
19 Group:          System/Hardware\
20 %description %1\
21 Touch configuration files for %1.\
22 %{nil}
23
24
25 %prep
26 %setup -q
27 # >> gbp-apply-patches    # auto-added by gbp
28 # << gbp-apply-patches    # auto-added by gbp
29 %build
30 cp %{SOURCE1001} .
31
32 %install
33
34 mkdir -p %{buildroot}/opt/etc/X11/xorg.conf.d
35 for f in `ls -1`; do
36         install -m 0644 $f %{buildroot}/opt/etc/X11/xorg.conf.d/
37 done
38
39 %touch_package cando
40 %files cando
41 %manifest device-config-touch.manifest
42 /opt/etc/X11/xorg.conf.d/60-cando-mtev.conf
43
44 %touch_package mxt224
45 %files mxt224
46 %manifest device-config-touch.manifest
47 /opt/etc/X11/xorg.conf.d/60-mxt224-mtev.conf
48
49 %touch_package sitronix
50 %files sitronix
51 %manifest device-config-touch.manifest
52 /opt/etc/X11/xorg.conf.d/70-sitronix-mtev.conf
53
54 %touch_package Hanvon
55 %files Hanvon
56 %manifest device-config-touch.manifest
57 /opt/etc/X11/xorg.conf.d/80-Hanvon-mtev.conf
58
59 %touch_package ILI
60 %files ILI
61 %manifest device-config-touch.manifest
62 /opt/etc/X11/xorg.conf.d/90-ILI-mtev.conf
63
64 %touch_package eGalax
65 %files eGalax
66 %manifest device-config-touch.manifest
67 /opt/etc/X11/xorg.conf.d/92-exopc-mtev.conf
68