Add config file for ft5x0x
[adaptation/device-config-touch.git] / packaging / device-config-touch.spec
1 Name:           device-config-touch
2 Version:        1
3 Release:        1
4 Summary:        Device specific configurations for Touch
5 Group:          System/Hardware
6 License:        GPLv2+
7 Source0:        %{name}-%{version}.tar.bz2
8 Source1001: packaging/device-config-touch.manifest 
9 # >> gbp-patch-tags         # auto-added by gbp
10 # << gbp-patch-tags         # auto-added by gbp
11 BuildArch: noarch
12
13 %description
14 Device specific configurations for Touch.
15
16 %define touch_package(n:) \
17 %package %1\
18 Summary:        Touch configuration files for %1\
19 Group:          System/Hardware\
20 %description %1\
21 Touch configuration files for %1.\
22 %{nil}
23
24
25 %prep
26 %setup -q
27 # >> gbp-apply-patches    # auto-added by gbp
28 # << gbp-apply-patches    # auto-added by gbp
29 %build
30 cp %{SOURCE1001} .
31
32 %install
33
34 mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d
35 install -m 0644 *.conf %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
36
37 %touch_package cando
38 %files cando
39 %{_sysconfdir}/X11/xorg.conf.d/60-cando-evdevmultitouch.conf
40 %manifest device-config-touch.manifest
41
42 %touch_package mxt224
43 %files mxt224
44 %{_sysconfdir}/X11/xorg.conf.d/60-mxt224-evdevmultitouch.conf
45 %manifest device-config-touch.manifest
46
47 %touch_package Atmel
48 %files Atmel
49 %manifest device-config-touch.manifest
50 %{_sysconfdir}/X11/xorg.conf.d/65-Atmel-mtev.conf
51
52 %touch_package sitronix
53 %files sitronix
54 %{_sysconfdir}/X11/xorg.conf.d/70-sitronix-mtev.conf
55 %manifest device-config-touch.manifest
56
57 %touch_package Hanvon
58 %files Hanvon
59 %{_sysconfdir}/X11/xorg.conf.d/80-Hanvon-mtev.conf
60 %manifest device-config-touch.manifest
61
62 %touch_package ILI
63 %files ILI
64 %{_sysconfdir}/X11/xorg.conf.d/90-ILI-mtev.conf
65 %manifest device-config-touch.manifest
66
67 %touch_package eGalax
68 %files eGalax
69 %{_sysconfdir}/X11/xorg.conf.d/92-exopc-mtev.conf
70 %manifest device-config-touch.manifest
71
72 %touch_package ft5x0x
73 %files ft5x0x
74 %{_sysconfdir}/X11/xorg.conf.d/61-ft5x0x-evdev.conf
75 %manifest device-config-touch.manifest
76