Initial code release
[profile/ivi/device-config-touch.git] / packaging / device-config-touch.spec
1 Name:           device-config-touch
2 Version:        1
3 Release:        1
4 Summary:        Device specific configurations for Touch
5 Group:          System/Hardware
6 License:        GPLv2+
7 Source0:        %{name}-%{version}.tar.bz2
8 # >> gbp-patch-tags         # auto-added by gbp
9 # << gbp-patch-tags         # auto-added by gbp
10 BuildArch: noarch
11
12 %description
13 Device specific configurations for Touch.
14
15 %define touch_package(n:) \
16 %package %1\
17 Summary:        Touch configuration files for %1\
18 Group:          System/Hardware\
19 %description %1\
20 Touch configuration files for %1.\
21 %{nil}
22
23
24 %prep
25 %setup -q
26 # >> gbp-apply-patches    # auto-added by gbp
27 # << gbp-apply-patches    # auto-added by gbp
28 %build
29
30 %install
31
32 mkdir -p %{buildroot}/opt/etc/X11/xorg.conf.d
33 for f in `ls -1`; do
34         install -m 0644 $f %{buildroot}/opt/etc/X11/xorg.conf.d/
35 done
36
37 %touch_package cando
38 %files cando
39 /opt/etc/X11/xorg.conf.d/60-cando-mtev.conf
40
41 %touch_package mxt224
42 %files mxt224
43 /opt/etc/X11/xorg.conf.d/60-mxt224-mtev.conf
44
45 %touch_package sitronix
46 %files sitronix
47 /opt/etc/X11/xorg.conf.d/70-sitronix-mtev.conf
48
49 %touch_package Hanvon
50 %files Hanvon
51 /opt/etc/X11/xorg.conf.d/80-Hanvon-mtev.conf
52
53 %touch_package ILI
54 %files ILI
55 /opt/etc/X11/xorg.conf.d/90-ILI-mtev.conf
56
57 %touch_package eGalax
58 %files eGalax
59 /opt/etc/X11/xorg.conf.d/92-exopc-mtev.conf
60