7e665ba8f44035336822a9813c250b10a856af40
[platform/upstream/dejavu-fonts.git] / packaging / dejavu-fonts.spec
1 %define _fontsdir               %{_datadir}/fonts
2 %define _ttffontsdir            %{_fontsdir}/truetype
3 %define _miscfontsdir           %{_fontsdir}/misc
4 %define _fontsconfdir           %{_sysconfdir}/fonts
5 %define _fontsconfddir          %{_fontsconfdir}/conf.d
6 %define _fontsconfavaildir      %{_datadir}/%{name}/conf.avail
7
8 Name:           dejavu-fonts
9 Version:        2.33
10 Release:        0
11 License:        Permissive
12 Summary:        DejaVu Truetype Fonts
13 Url:            http://dejavu.sourceforge.net/
14 Group:          System/Fonts
15 Source:         dejavu-fonts-ttf-%{version}.tar.bz2
16 BuildArch:      noarch
17
18 %description
19 The DejaVu fonts are a font family based on the Vera Fonts.
20 Its purpose is to provide a wider range of characters while
21 maintaining the original look and feel through the process
22 of collaborative development (see authors), under a Free license.
23
24 %prep
25 %setup -n %{name}-ttf-%{version}
26
27 %build
28
29 %install
30 mkdir -p %{buildroot}%{_ttffontsdir}/
31 install -m 0644 ttf/*.ttf %{buildroot}%{_ttffontsdir}/
32
33
34 %post
35 if [ -x %{_bindir}/fc-cache ]; then 
36     %{_bindir}/fc-cache %{_ttffontsdir} || :
37 fi
38
39 %postun
40 if [ -x %{_bindir}/fc-cache ]; then 
41     %{_bindir}/fc-cache %{_ttffontsdir} || :
42 fi
43
44 %files
45 %defattr(-,root,root,755)
46 %license LICENSE
47 %{_ttffontsdir}/
48