resetting manifest requested domain to floor
[platform/upstream/dejavu-fonts.git] / packaging / dejavu-fonts.spec
1 %define _fontsdir               %{_datadir}/fonts
2 %define _ttffontsdir            %{_fontsdir}/truetype
3 %define _miscfontsdir           %{_fontsdir}/misc
4 %define _fontsconfdir           %{_sysconfdir}/fonts
5 %define _fontsconfddir          %{_fontsconfdir}/conf.d
6 %define _fontsconfavaildir      %{_datadir}/%{name}/conf.avail
7
8 Name:           dejavu-fonts
9 Version:        2.33
10 Release:        0
11 License:        Permissive
12 Summary:        DejaVu Truetype Fonts
13 Url:            http://dejavu.sourceforge.net/
14 Group:          System/Fonts
15 Source:         dejavu-fonts-ttf-%{version}.tar.bz2
16 Source1001:     dejavu-fonts.manifest
17 BuildArch:      noarch
18
19 %description
20 The DejaVu fonts are a font family based on the Vera Fonts.
21 Its purpose is to provide a wider range of characters while
22 maintaining the original look and feel through the process
23 of collaborative development (see authors), under a Free license.
24
25 %prep
26 %setup -n %{name}-ttf-%{version}
27 cp %{SOURCE1001} .
28
29 %build
30
31 %install
32 mkdir -p %{buildroot}%{_ttffontsdir}/
33 install -m 0644 ttf/*.ttf %{buildroot}%{_ttffontsdir}/
34
35
36 %post
37 if [ -x %{_bindir}/fc-cache ]; then 
38     %{_bindir}/fc-cache %{_ttffontsdir} || :
39 fi
40
41 %postun
42 if [ -x %{_bindir}/fc-cache ]; then 
43     %{_bindir}/fc-cache %{_ttffontsdir} || :
44 fi
45
46 %files
47 %manifest %{name}.manifest
48 %defattr(-,root,root,755)
49 %license LICENSE
50 %{_ttffontsdir}/
51