packaging: use configure instead of autogen
[platform/upstream/dbus-python.git] / packaging / dbus-python.spec
1 Name:           dbus-python
2 Version:        1.2.0
3 Release:        0
4 Summary:        Python bindings for D-Bus
5 License:        MIT
6 Group:          System/Libraries
7 Url:            http://www.freedesktop.org/wiki/Software/DBusBindings/
8 Source0:        http://dbus.freedesktop.org/releases/dbus-python/dbus-python-%{version}.tar.gz
9 Source1001:     dbus-python.manifest
10 BuildRequires:  fdupes
11 BuildRequires:  python-devel
12 BuildRequires:  pkgconfig(dbus-1)
13 BuildRequires:  pkgconfig(dbus-glib-1)
14 Requires:       libxml2-python
15 Requires:       python-xml
16
17 %description
18 D-Bus python bindings for use with python programs.
19
20 %package  devel
21 Summary:        Python bindings for D-Bus
22 Requires:       dbus-python = %{version}
23
24 %description  devel
25 Developer files for Python bindings for D-Bus.
26
27 %prep
28 %setup -q 
29 cp %{SOURCE1001} .
30
31 %build
32 export CFLAGS="%{optflags} -fstack-protector -fno-strict-aliasing -fPIC"
33 %configure --docdir=%{_docdir}/dbus-python
34 %__make %{?_smp_mflags}
35
36 %install
37 %make_install
38
39
40 %remove_docs
41 %fdupes -s %{buildroot}
42
43 %files
44 %manifest %{name}.manifest
45 %license COPYING
46 %defattr(-,root,root,-)
47 %{python_sitelib}/*
48 %{python_sitearch}/*
49
50 %files devel
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{_includedir}/dbus-1.0/dbus/dbus-python.h
54 %{_libdir}/pkgconfig/dbus-python.pc