Rearrange LICENSE
[platform/upstream/dbus-glib.git] / packaging / dbus-glib.spec
1 Name:           dbus-glib
2 Version:        0.100.2
3 Release:        0
4 License:        AFL-2.1 or GPL-2.0+
5 Summary:        GLib bindings for D-Bus
6 Url:            http://www.freedesktop.org/software/dbus/
7 Group:          System/Libraries
8 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-%{version}.tar.gz
9 Source1001:     dbus-glib.manifest
10 BuildRequires:  autoconf
11 BuildRequires:  expat-devel
12 BuildRequires:  gettext-tools
13 BuildRequires:  libtool
14 BuildRequires:  pkgconfig(dbus-1)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(libxml-2.0)
17
18 %description
19 D-Bus add-on library to integrate the standard D-Bus library with
20 the GLib thread abstraction and main loop.
21
22 %package devel
23 Summary:        Libraries and headers for the D-Bus GLib bindings
24 Group:          Development/Libraries
25 Requires:       %{name} = %{version}
26
27 %description devel
28 Headers and static libraries for the D-Bus GLib bindings
29
30 %prep
31 %setup -q
32 cp %{SOURCE1001} .
33
34 %build
35
36 %configure --disable-tests \
37     --enable-verbose-mode=yes \
38     --enable-asserts=yes \
39     --disable-gtk-doc
40
41 make %{?_smp_mflags}
42
43 %install
44 %make_install
45
46 # don't care about bash completion in a consumer device
47 rm -rf %{buildroot}%{_sysconfdir}/bash_completion.d/dbus-bash-completion.sh
48 rm -rf %{buildroot}%{_prefix}/libexec/dbus-bash-completion-helper
49
50 %docs_package
51
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56 %files
57 %manifest %{name}.manifest
58 %license COPYING LICENSE.AFL-2.1 LICENSE.GPL-2.0+
59 %{_libdir}/*glib*.so.*
60
61 %files devel
62 %manifest %{name}.manifest
63 %license COPYING LICENSE.AFL-2.1 LICENSE.GPL-2.0+
64 %{_libdir}/lib*.so
65 %{_libdir}/pkgconfig/dbus-glib-1.pc
66 %{_includedir}/dbus-1.0/dbus/*
67 %{_bindir}/dbus-binding-tool