Remove Tapi dependendy
[platform/core/connectivity/data-router.git] / packaging / data-router.spec
1 Name:       data-router
2 Summary:    Data Router
3 Version:    0.2.17
4 Release:    1
5 Group:      Connectivity/Service
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     data-router.manifest
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(dbus-glib-1)
12 BuildRequires: pkgconfig(vconf)
13 Requires(post): /usr/bin/vconftool
14
15 %description
16 Working as a Router for USB communication
17 For USB serial communication, reads/writes usb node and routes them to Socket client application.
18
19 %prep
20 %setup -q
21 cp %{SOURCE1001} .
22
23 %build
24 %cmake .
25 make %{?jobs:-j%jobs}
26
27 %install
28 %make_install
29
30
31 %post
32 /usr/bin/vconftool set -t int memory/data_router/osp_serial_open "0" -u 0 -i -f
33
34
35 %files
36 %manifest %{name}.manifest
37 %defattr(-, root, root)
38 %license LICENSE
39 /usr/bin/data-router