a14cacf5b23c031926d36310f7c59a8296c79ffd
[platform/core/connectivity/data-router.git] / packaging / data-router.spec
1 Name:       data-router
2 Summary:    Data Router
3 Version:    0.2.18
4 Release:    1
5 Group:      Connectivity/Service
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     data-router.manifest
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(glib-2.0) >= 2.26
11 BuildRequires: pkgconfig(gio-2.0)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(vconf)
14 Requires(post): /usr/bin/vconftool
15
16 %description
17 Working as a Router for USB communication
18 For USB serial communication, reads/writes usb node and routes them to Socket client application.
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23
24 %build
25 %cmake .
26 make %{?jobs:-j%jobs}
27
28 %install
29 %make_install
30
31
32 %post
33 /usr/bin/vconftool set -t int memory/data_router/osp_serial_open "0" -u 0 -i -f
34
35
36 %files
37 %manifest %{name}.manifest
38 %defattr(-, root, root)
39 %license LICENSE
40 /usr/bin/data-router