usb: apply new enums for usb-gadget mode
[platform/core/connectivity/data-router.git] / packaging / data-router.spec
1 Name:       data-router
2 Summary:    Data Router
3 Version:    0.2.18
4 Release:    1
5 Group:      Connectivity/Service
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     data-router.manifest
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(glib-2.0) >= 2.26
11 BuildRequires: pkgconfig(gio-2.0)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(capi-system-device)
15 Requires(post): /usr/bin/vconftool
16
17 %description
18 Working as a Router for USB communication
19 For USB serial communication, reads/writes usb node and routes them to Socket client application.
20
21 %prep
22 %setup -q
23 cp %{SOURCE1001} .
24
25 %build
26 %cmake .
27 make %{?jobs:-j%jobs}
28
29 %install
30 %make_install
31
32
33 %post
34 /usr/bin/vconftool set -t int memory/data_router/osp_serial_open "0" -u 0 -i -f
35
36
37 %files
38 %manifest %{name}.manifest
39 %defattr(-, root, root)
40 %license LICENSE
41 /usr/bin/data-router