Merge branch 'tizen_base' of ssh://review.tizen.org:29418/platform/upstream/dash...
[platform/upstream/dash.git] / packaging / dash.spec
1 Name:           dash
2 Version:        0.5.7
3 Release:        4
4 Summary:        Small and fast POSIX-compliant shell
5 Group:          Base/Utilities
6 License:        BSD-3-Clause and GPL-2.0+
7 URL:            http://gondor.apana.org.au/~herbert/dash/
8 Source0:        http://gondor.apana.org.au/~herbert/dash/files/dash-%{version}.tar.gz
9 Source1001:     dash.manifest
10
11 %description
12 DASH is a POSIX-compliant implementation of /bin/sh that aims to be as small as
13 possible. It does this without sacrificing speed where possible. In fact, it is
14 significantly faster than bash (the GNU Bourne-Again SHell) for most tasks.
15
16 %prep
17 %setup -q
18 cp %{SOURCE1001} .
19
20 %build
21 %configure
22 make %{?_smp_mflags}
23
24 %install
25 make install DESTDIR=%{buildroot}
26 mkdir -p %{buildroot}/bin
27 mv %{buildroot}%{_bindir}/dash %{buildroot}/bin/
28 rm -rf %{buildroot}%{_bindir}/
29
30 %post
31 grep -q '^/bin/dash$' /etc/shells || echo '/bin/dash' >> /etc/shells
32
33 %postun
34 if [ $1 -eq 0 ]; then
35     sed -i '/^\/bin\/dash$/d' /etc/shells
36 fi
37
38 %docs_package
39
40 %files
41 %manifest %{name}.manifest
42 %license COPYING
43 /bin/dash
44