Merge branch 'devel/x11' into tizen
[platform/upstream/damageproto.git] / packaging / damageproto.spec
1 %bcond_with x
2
3 Name:           damageproto
4 Version:        1.2.1
5 Release:        1
6 License:        MIT
7 Summary:        X
8 Url:            http://www.x.org
9 Group:          Development/System
10 Source0:        %{name}-%{version}.tar.bz2
11 Source1001:     damageproto.manifest
12
13 BuildRequires:  pkgconfig
14 BuildRequires:  pkgconfig(xorg-macros)
15
16 %if !%{with x}
17 ExclusiveArch:
18 %endif
19
20 %description
21 %{summary}.
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 %configure --disable-static \
29              --libdir=%{_datadir} \
30              --without-xmlto
31
32 make %{?_smp_mflags}
33
34 %install
35 %make_install
36
37 %remove_docs
38
39 %files
40 %manifest %{name}.manifest
41 %license COPYING
42 %defattr(-,root,root,-)
43 %{_includedir}/X11/extensions/*.h
44 %{_datadir}/pkgconfig/*.pc