2 Summary: The OpenGLES Canvas Core Library
5 Group: System/Libraries
7 URL: https://review.tizen.org/git/?p=platform/core/uifw/dali-core.git;a=summary
8 Source0: %{name}-%{version}.tar.gz
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 Requires: boost-thread
13 BuildRequires: pkgconfig
15 BuildRequires: boost-devel
16 BuildRequires: boost-thread
19 The OpenGLES Canvas Core Library provides a 3D scene graph
21 ##############################
23 ##############################
25 Summary: Development components for the OpenGLES Canvas Core Library
26 Group: Development/Building
27 Requires: %{name} = %{version}-%{release}
28 Requires: %{name}-integration-devel = %{version}-%{release}
31 Development components for the OpenGLES Canvas Core Library - public headers and package config
33 ##############################
35 ##############################
36 %package integration-devel
37 Summary: Integration development package for the OpenGLES Canvas
38 Group: Development/Building
39 Requires: %{name} = %{version}-%{release}
41 %description integration-devel
42 Integration development package for the OpenGLES Canvas - headers for integrating with an adaptor/platform abstraction library.
44 ##############################
46 ##############################
49 %define dali_data_rw_dir /opt/usr/share/dali/
50 %define dali_data_ro_dir /usr/share/dali/
51 %define shader_bin_dir %{dali_data_rw_dir}/core/shaderbin
52 %define dev_include_path %{_includedir}
54 ##############################
56 ##############################
59 CXXFLAGS+=" -Wall -g -Os -DNDEBUG -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
60 LDFLAGS+=" -Wl,--rpath=$PREFIX/lib -Wl,--as-needed -Wl,--gc-sections -lgcc_s -lgcc -lpthread"
62 %if 0%{?sec_build_binary_debug_enable}
63 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
64 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
65 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
69 CXXFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
73 cd %{_builddir}/%{name}-%{version}/build/tizen
75 DALI_DATA_RW_DIR="%{dali_data_rw_dir}"
76 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
77 export DALI_DATA_RW_DIR
78 export DALI_DATA_RO_DIR
80 CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS;
81 CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS;
82 LDFLAGS="${LDFLAGS:-%optflags}" ; export LDFLAGS;
84 --program-prefix=%{?_program_prefix} \
86 --exec-prefix=%{_exec_prefix} \
88 --sbindir=%{_sbindir} \
89 --sysconfdir=%{_sysconfdir} \
90 --datadir=%{_datadir} \
91 --includedir=%{_includedir} \
93 --libexecdir=%{_libexecdir} \
94 --localstatedir=%{_localstatedir} \
95 --sharedstatedir=%{_sharedstatedir} \
101 ##############################
103 ##############################
107 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
110 mkdir -p %{buildroot}/usr/share/license
111 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
114 ##############################
116 ##############################
119 chown 5000:5000 %{shader_bin_dir}
120 rm -rf %{shader_bin_dir}/*
123 ##############################
125 ##############################
128 rm -rf %{shader_bin_dir}
131 ##############################
132 # Files in Binary Packages
133 ##############################
136 %if 0%{?enable_dali_smack_rules}
137 %manifest dali.manifest-smack
139 %manifest dali.manifest
141 %defattr(-,root,root,-)
142 %{_libdir}/lib%{name}-core.so*
143 %defattr(-,app,app,-)
144 %dir %{shader_bin_dir}
145 %{_datadir}/license/%{name}
148 %defattr(-,root,root,-)
149 %{_libdir}/pkgconfig/*.pc
150 %{dev_include_path}/%{name}/public-api/*
152 %files integration-devel
153 %defattr(-,root,root,-)
154 %{_includedir}/%{name}/integration-api/*