(Gestures) Ensure an update is done if gesture properties are updated.
[platform/core/uifw/dali-core.git] / packaging / dali.spec
1 Name:       dali
2 Summary:    The OpenGLES Canvas Core Library
3 Version:    0.9.13
4 Release:    1
5 Group:      System/Libraries
6 License:    Flora
7 URL:        TO_BE_FILLED
8 Source0:    %{name}-%{version}.tar.gz
9
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 Requires:       boost-thread
13 BuildRequires:  pkgconfig
14 BuildRequires:  opengl-es-devel
15 BuildRequires:  gawk
16 BuildRequires:  boost-devel
17 BuildRequires:  boost-thread
18 BuildRequires:  sec-product-features
19
20 %description
21 The OpenGLES Canvas Core Library
22
23 ##############################
24 # devel
25 ##############################
26 # This should be used only for building dali-adaptor and dali-toolkit independently of
27 # dali-capi - i.e. to break cyclic dependencies.
28 %package devel
29 Summary:    Development components for the OpenGLES Canvas Core Library
30 Group:      Development/Libs
31 Requires:   %{name} = %{version}-%{release}
32 Requires:   %{name}-integration-devel = %{version}-%{release}
33 %ifarch %{ix86}
34 Requires:   opengl-es-devel
35 %endif
36
37 %description devel
38 Development components for the OpenGLES Canvas Core Library
39
40 ##############################
41 # integration-devel
42 ##############################
43 %package integration-devel
44 Summary:    Integration development package for the OpenGLES Canvas
45 Group:      Development/Libs
46 Requires:   %{name} = %{version}-%{release}
47
48 %description integration-devel
49 Integration development package for the OpenGLES Canvas
50
51 ##############################
52 # Preparation
53 ##############################
54 %prep
55 %setup -q
56 %define dali_data_rw_dir /opt/usr/share/dali/
57 %define dali_data_ro_dir /usr/share/dali/
58 %define shader_bin_dir   %{dali_data_rw_dir}/core/shaderbin
59 %define dev_include_path %{_includedir}
60
61 ##############################
62 # Build
63 ##############################
64 %build
65 PREFIX="/usr"
66 CXXFLAGS+=" -Wall -g -O2 -DNDEBUG -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
67 LDFLAGS+=" -Wl,--rpath=$PREFIX/lib -Wl,--as-needed -Wl,--gc-sections -lgcc_s -lgcc -lpthread"
68
69 %if 0%{?sec_build_binary_debug_enable}
70 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
71 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
72 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
73 %endif
74
75 %ifarch %{arm}
76 CXXFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
77 %endif
78
79 libtoolize --force
80 cd %{_builddir}/%{name}-%{version}/build/slp && autoreconf --install
81 cd %{_builddir}/%{name}-%{version}/build/slp && CXXFLAGS="$CXXFLAGS" LDFLAGS="$LDFLAGS" DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}" ./configure --prefix="$PREFIX"
82
83 make %{?jobs:-j%jobs}
84
85 ##############################
86 # Installation
87 ##############################
88 %install
89 rm -rf %{buildroot}
90 cd build/slp
91 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
92
93 # LICENSE
94 mkdir -p %{buildroot}/usr/share/license
95 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
96
97 %if 0%{?sec_product_feature_graphics_adreno}
98   mkdir -p %{buildroot}%{shader_bin_dir}
99   mv %{_builddir}/%{name}-%{version}/dali/shaderbins/adreno330/*.dali-bin %{buildroot}%{shader_bin_dir}
100 %endif
101
102 ##############################
103 # Post Install
104 ##############################
105 %post
106 /sbin/ldconfig
107 chown 5000:5000 %{shader_bin_dir}
108 %if 0%{?sec_product_feature_graphics_adreno}
109 %else
110   rm -rf %{shader_bin_dir}/*
111 %endif
112 exit 0
113
114 ##############################
115 # Post Uninstall
116 ##############################
117 %postun
118 /sbin/ldconfig
119 rm -rf %{shader_bin_dir}
120 exit 0
121
122 ##############################
123 # Files in Binary Packages
124 ##############################
125
126 %files
127 %manifest dali.manifest
128 %defattr(-,root,root,-)
129 %{_libdir}/lib%{name}-core.so*
130 %defattr(-,app,app,-)
131 %if 0%{?sec_product_feature_graphics_adreno}
132   %{shader_bin_dir}/*
133 %endif
134 %dir %{shader_bin_dir}
135 %{_datadir}/license/%{name}
136
137 %files devel
138 %defattr(-,root,root,-)
139 %{_libdir}/pkgconfig/*.pc
140 %{dev_include_path}/%{name}/public-api/*
141
142 %files integration-devel
143 %defattr(-,root,root,-)
144 %{_includedir}/%{name}/integration-api/*