Added key extension
[platform/core/uifw/dali-extension.git] / packaging / dali-extension.spec
1 # NOTES
2 # This spec file is used to build DALi Extensions
3 #
4 # gbs will try to download the build.conf for the platform automatically from the repo location when
5 # performing a gbs build ( use gbs build -v to see it download location) E.g.
6 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
7
8 Name:       dali-extension
9 Summary:    The DALi Tizen Extensions
10 Version:    1.2.42
11 Release:    1
12 Group:      System/Libraries
13 License:    Apache-2.0 and BSD-3-Clause and MIT
14 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-extensions.git;a=summary
15 Source0:    %{name}-%{version}.tar.gz
16
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19
20 BuildRequires:  pkgconfig
21 BuildRequires:  pkgconfig(dali-core)
22 BuildRequires:  pkgconfig(dali-adaptor)
23 BuildRequires:  pkgconfig(dali-toolkit)
24 BuildRequires:  pkgconfig(dlog)
25
26 %description
27 dali-extension
28
29 ##############################
30 # devel
31 ##############################
32 %package devel
33 Summary:    Development components for the DALi Extension
34 Group:      Development/Building
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 Development components for the DALi Tizen Extensions - public headers and package configs
39
40 V##############################
41 # Dali Key Extension
42 ##############################
43
44 %package key-extension
45 Summary:    Plugin to support extension keys for Dali
46 Group:      System/Libraries
47
48 %description key-extension
49 Plugin to support extension keys for Dali
50
51 ##############################
52 # Preparation
53 ##############################
54 %prep
55 %setup -q
56
57 #Use TZ_PATH when tizen version is 3.x or greater
58
59 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
60 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
61 %define dev_include_path %{_includedir}
62
63 ##############################
64 # Build
65 ##############################
66 %build
67 PREFIX+="/usr"
68 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
69 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
70
71 libtoolize --force
72 cd %{_builddir}/%{name}-%{version}/build/tizen
73 autoreconf --install
74
75 %configure --prefix=$PREFIX \
76            --enable-keyextension
77
78 make %{?jobs:-j%jobs}
79
80 ##############################
81 # Installation
82 ##############################
83 %install
84 rm -rf %{buildroot}
85 cd build/tizen
86 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
87
88 %pre
89 exit 0
90
91 ##############################
92 #  Post Install new package
93 ##############################
94 %post
95 /sbin/ldconfig
96 exit 0
97
98 %post key-extension
99 /sbin/ldconfig
100 exit 0
101
102 ##############################
103 #   Pre Uninstall old package
104 ##############################
105 %preun
106 exit 0
107
108 ##############################
109 #   Post Uninstall old package
110 ##############################
111 %postun
112 /sbin/ldconfig
113 exit 0
114
115 %postun key-extension
116 /sbin/ldconfig
117 exit 0
118
119 ##############################
120 # Files in Binary Packages
121 ##############################
122
123 %files
124 %manifest dali-extension.manifest
125 %defattr(-,root,root,-)
126 %license LICENSE
127
128 %files devel
129 %defattr(-,root,root,-)
130 %{_includedir}/%{name}/
131 %{_libdir}/pkgconfig/*.pc
132
133 %files key-extension
134 %manifest dali-extension.manifest
135 %defattr(-,root,root,-)
136 %{_libdir}/libdali-key-extension.so*
137 %license LICENSE