[4.0] Added checker of video texture
[platform/core/uifw/dali-extension.git] / packaging / dali-extension.spec
1 # NOTES
2 # This spec file is used to build DALi Extensions
3 #
4 # gbs will try to download the build.conf for the platform automatically from the repo location when
5 # performing a gbs build ( use gbs build -v to see it download location) E.g.
6 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
7
8 Name:       dali-extension
9 Summary:    The DALi Tizen Extensions
10 Version:    1.2.60
11 Release:    1
12 Group:      System/Libraries
13 License:    Apache-2.0 and BSD-3-Clause and MIT
14 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-extensions.git;a=summary
15 Source0:    %{name}-%{version}.tar.gz
16
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19
20 BuildRequires:  pkgconfig
21 BuildRequires:  pkgconfig(dali-core)
22 BuildRequires:  pkgconfig(dali-adaptor)
23 BuildRequires:  pkgconfig(dali-toolkit)
24 BuildRequires:  pkgconfig(dlog)
25
26 %description
27 dali-extension
28
29 ##############################
30 # devel
31 ##############################
32 %package devel
33 Summary:    Development components for the DALi Extension
34 Group:      Development/Building
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 Development components for the DALi Tizen Extensions - public headers and package configs
39
40 ##############################
41 # Dali Key Extension
42 ##############################
43
44 %package key-extension
45 Summary:    Plugin to support extension keys for Dali
46 Group:      System/Libraries
47
48 %description key-extension
49 Plugin to support extension keys for Dali
50
51 ##############################
52 # Dali VideoPlayer Plugin
53 ##############################
54
55 %package video-player-plugin
56 Summary:    Plugin to play a video file for Dali
57 Group:      System/Libraries
58 BuildRequires: pkgconfig(ecore-wayland)
59 BuildRequires: pkgconfig(capi-media-player)
60 BuildRequires: pkgconfig(capi-system-info)
61
62 %description video-player-plugin
63 VideoPlayer plugin to play a video file for Dali
64
65 ##############################
66 # Preparation
67 ##############################
68 %prep
69 %setup -q
70
71 #Use TZ_PATH when tizen version is 3.x or greater
72
73 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
74 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
75 %define dev_include_path %{_includedir}
76
77 ##############################
78 # Build
79 ##############################
80 %build
81 PREFIX+="/usr"
82 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
83 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
84
85 libtoolize --force
86 cd %{_builddir}/%{name}-%{version}/build/tizen
87 autoreconf --install
88
89 %configure --prefix=$PREFIX \
90            --enable-keyextension
91
92 make %{?jobs:-j%jobs}
93
94 ##############################
95 # Installation
96 ##############################
97 %install
98 rm -rf %{buildroot}
99 cd build/tizen
100 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
101
102 %pre
103 exit 0
104
105 ##############################
106 #  Post Install new package
107 ##############################
108 %post
109 /sbin/ldconfig
110 exit 0
111
112 %post key-extension
113 /sbin/ldconfig
114 exit 0
115
116 %post video-player-plugin
117 /sbin/ldconfig
118 exit 0
119
120 ##############################
121 #   Pre Uninstall old package
122 ##############################
123 %preun
124 exit 0
125
126 ##############################
127 #   Post Uninstall old package
128 ##############################
129 %postun
130 /sbin/ldconfig
131 exit 0
132
133 %postun key-extension
134 /sbin/ldconfig
135 exit 0
136
137 %postun video-player-plugin
138 /sbin/ldconfig
139 exit 0
140
141 ##############################
142 # Files in Binary Packages
143 ##############################
144
145 %files
146 %manifest dali-extension.manifest
147 %defattr(-,root,root,-)
148 %license LICENSE
149
150 %files devel
151 %defattr(-,root,root,-)
152 %{_includedir}/%{name}/
153 %{_libdir}/pkgconfig/*.pc
154
155 %files key-extension
156 %manifest dali-extension.manifest
157 %defattr(-,root,root,-)
158 %{_libdir}/libdali-key-extension.so*
159 %license LICENSE
160
161 %files video-player-plugin
162 %manifest dali-extension.manifest
163 %defattr(-,root,root,-)
164 %{_libdir}/libdali-video-player-plugin.so*
165 %license LICENSE