510b81dbed85f3140cc231a81021dcd7eaf12253
[platform/core/uifw/dali-extension.git] / packaging / dali-extension.spec
1 # NOTES
2 # This spec file is used to build DALi Extensions
3 #
4 # gbs will try to download the build.conf for the platform automatically from the repo location when
5 # performing a gbs build ( use gbs build -v to see it download location) E.g.
6 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
7
8 Name:       dali-extension
9 Summary:    The DALi Tizen Extensions
10 Version:    1.3.48
11 Release:    1
12 Group:      System/Libraries
13 License:    Apache-2.0 and BSD-3-Clause and MIT
14 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-extensions.git;a=summary
15 Source0:    %{name}-%{version}.tar.gz
16
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19
20 BuildRequires:  pkgconfig
21 BuildRequires:  pkgconfig(dali-core)
22 BuildRequires:  pkgconfig(dali-adaptor)
23 BuildRequires:  pkgconfig(dali-toolkit)
24 BuildRequires:  pkgconfig(dlog)
25
26 %description
27 dali-extension
28
29 ##############################
30 # devel
31 ##############################
32 %package devel
33 Summary:    Development components for the DALi Extension
34 Group:      Development/Building
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 Development components for the DALi Tizen Extensions - public headers and package configs
39
40 ##############################
41 # Dali Key Extension
42 ##############################
43
44 %package key-extension
45 Summary:    Plugin to support extension keys for Dali
46 Group:      System/Libraries
47
48 %description key-extension
49 Plugin to support extension keys for Dali
50
51 ##############################
52 # Dali VideoPlayer Plugin
53 ##############################
54
55 %package video-player-plugin
56 Summary:    Plugin to play a video file for Dali
57 Group:      System/Libraries
58 BuildRequires: pkgconfig(ecore-wayland)
59 BuildRequires: pkgconfig(capi-media-player)
60 BuildRequires: pkgconfig(capi-system-info)
61
62 %description video-player-plugin
63 VideoPlayer plugin to play a video file for Dali
64
65 ##############################
66 # Dali Web Engine chromium Plugin
67 ##############################
68
69 %package web-engine-chromium-plugin
70 Summary:    Plugin to support WebView for Dali
71 Group:      System/Libraries
72 BuildRequires: pkgconfig(libtbm)
73 BuildRequires: pkgconfig(chromium-efl)
74 BuildRequires: pkgconfig(elementary)
75
76 %description web-engine-chromium-plugin
77 Web Engine chromium plugin to support WebView for Dali
78
79 ##############################
80 # Preparation
81 ##############################
82 %prep
83 %setup -q
84
85 #Use TZ_PATH when tizen version is 3.x or greater
86
87 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
88 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
89 %define dev_include_path %{_includedir}
90
91 ##############################
92 # Build
93 ##############################
94 %build
95 PREFIX+="/usr"
96 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
97 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
98
99 libtoolize --force
100 cd %{_builddir}/%{name}-%{version}/build/tizen
101 autoreconf --install
102
103 %configure --prefix=$PREFIX \
104            --enable-keyextension
105
106 make %{?jobs:-j%jobs}
107
108 ##############################
109 # Installation
110 ##############################
111 %install
112 rm -rf %{buildroot}
113 cd build/tizen
114 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
115
116 %pre
117 exit 0
118
119 ##############################
120 #  Post Install new package
121 ##############################
122 %post
123 /sbin/ldconfig
124 exit 0
125
126 %post key-extension
127 /sbin/ldconfig
128 exit 0
129
130 %post video-player-plugin
131 /sbin/ldconfig
132 exit 0
133
134 %post web-engine-chromium-plugin
135 /sbin/ldconfig
136 exit 0
137
138 ##############################
139 #   Pre Uninstall old package
140 ##############################
141 %preun
142 exit 0
143
144 ##############################
145 #   Post Uninstall old package
146 ##############################
147 %postun
148 /sbin/ldconfig
149 exit 0
150
151 %postun key-extension
152 /sbin/ldconfig
153 exit 0
154
155 %postun video-player-plugin
156 /sbin/ldconfig
157 exit 0
158
159 %postun web-engine-chromium-plugin
160 /sbin/ldconfig
161 exit 0
162
163 ##############################
164 # Files in Binary Packages
165 ##############################
166
167 %files
168 %manifest dali-extension.manifest
169 %defattr(-,root,root,-)
170 %license LICENSE
171
172 %files devel
173 %defattr(-,root,root,-)
174 %{_includedir}/%{name}/
175 %{_libdir}/pkgconfig/*.pc
176
177 %files key-extension
178 %manifest dali-extension.manifest
179 %defattr(-,root,root,-)
180 %{_libdir}/libdali-key-extension.so*
181 %license LICENSE
182
183 %files video-player-plugin
184 %manifest dali-extension.manifest
185 %defattr(-,root,root,-)
186 %{_libdir}/libdali-video-player-plugin.so*
187 %license LICENSE
188
189 %files web-engine-chromium-plugin
190 %manifest dali-extension.manifest
191 %defattr(-,root,root,-)
192 %{_libdir}/libdali-web-engine-chromium-plugin.so*
193 %license LICENSE