DALi Version 1.3.27
[platform/core/uifw/dali-csharp-binder.git] / packaging / dali-csharp-binder.spec
1
2 Name: dali-csharp-binder
3 Version: 1.3.27
4 Release: 1
5 Summary: build dali csharp binder
6 License: Apache-2.0 and BSD-3-Clause and MIT
7 Group: uifw/graphic
8 Source: %{name}-%{version}.tar.xz
9
10 BuildRequires: pkgconfig(dali-core)
11 BuildRequires: pkgconfig(dali-adaptor)
12 BuildRequires: pkgconfig(dali-toolkit)
13 BuildRequires: pkgconfig(widget_viewer_dali)
14 %if 0%{?tizen_version_major} >= 5
15 BuildRequires: pkgconfig(ecore-wl2)
16 %else
17 BuildRequires:  pkgconfig(ecore-wayland)
18 %endif
19
20 %description
21 dali-csharp-binder
22
23 %if 0%{?tizen_version_major} >= 5
24 CFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
25 CXXFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
26 %endif
27
28 ##############################
29 # devel
30 ##############################
31 %package devel
32 Summary: build dali csharp binder
33 Group: Development/Building
34 Requires: %{name} = %{version}-%{release}
35
36 %description devel
37 This package includes developer files common to all packages.
38
39 ##############################
40 # Preparation
41 ##############################
42 %prep
43 %setup -q
44
45 ##############################
46 # Build
47 ##############################
48 %build
49 %autogen
50 # added for key grab binding only for tizen
51 # Do not merge this on tizen branch!
52 %if 0%{?tizen_version_major} >= 5
53 %configure --enable-ecoreWl2=yes \
54            --enable-tizenBuild=no
55 %else
56 %configure --enable-tizenBuild=no
57 %endif
58
59 make %{?_smp_mflags}
60
61 ##############################
62 # Installation
63 ##############################
64 %install
65 %make_install
66
67 ##############################
68 # Files in Binary Packages
69 ##############################
70 %files -n %{name}
71 %manifest dali-csharp-binder.manifest     
72 %defattr(-,root,root,-)
73 %{_libdir}/lib%{name}.so*
74
75 %files devel
76 %defattr(-,root,root,-)
77 %dir %{_includedir}/%{name}/
78 %{_includedir}/%{name}/*
79 %{_libdir}/pkgconfig/%{name}.pc
80