818b4c6af19175ccba7e69fcde29ea6e90b840bb
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.5.1
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30 Provides: libdali-adaptor-cxx11.so
31 Provides: libdali-adaptor-cxx11.so.0
32 Provides: libdali-adaptor-cxx11.so.0.0.0
33 Provides: libdali-adaptor.so
34 Provides: libdali-adaptor.so.0
35 Provides: libdali-adaptor.so.0.0.0
36
37 %define tizen_platform_config_supported 1
38 BuildRequires:  pkgconfig(libtzplatform-config)
39
40 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
41 # if wearable || "undefined"
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
43 BuildRequires:  pkgconfig(capi-appfw-watch-application)
44 BuildRequires:  pkgconfig(appcore-watch)
45 BuildRequires:  pkgconfig(screen_connector_provider)
46 %endif
47
48 BuildRequires:  pkgconfig(gles20)
49 BuildRequires:  pkgconfig(glesv2)
50 BuildRequires:  pkgconfig(ttrace)
51
52 BuildRequires:  dali-devel
53 BuildRequires:  dali-integration-devel
54
55 BuildRequires:  pkgconfig
56 BuildRequires:  gawk
57 BuildRequires:  cmake
58 BuildRequires:  giflib-devel
59 BuildRequires:  pkgconfig(fontconfig)
60 BuildRequires:  libjpeg-turbo-devel
61 BuildRequires:  pkgconfig(vconf)
62 BuildRequires:  tts-devel
63 BuildRequires:  pkgconfig(dlog)
64 BuildRequires:  libdrm-devel
65 BuildRequires:  pkgconfig(libexif)
66 BuildRequires:  pkgconfig(libpng)
67 BuildRequires:  pkgconfig(egl)
68 BuildRequires:  libcurl-devel
69 BuildRequires:  pkgconfig(harfbuzz)
70 BuildRequires:  fribidi-devel
71
72 BuildRequires:  pkgconfig(capi-system-info)
73 BuildRequires:  pkgconfig(capi-system-sensor)
74
75 BuildRequires:  pkgconfig(cairo)
76
77 BuildRequires:  pkgconfig(wayland-egl)
78 BuildRequires:  pkgconfig(wayland-client)
79 BuildRequires:  wayland-devel
80 BuildRequires:  wayland-extension-client-devel
81
82 # dali-adaptor uses ecore mainloop
83 %if 0%{?tizen_version_major} >= 5
84 BuildRequires:  pkgconfig(ecore-wl2)
85 BuildRequires:  pkgconfig(wayland-egl-tizen)
86 %else
87 BuildRequires:  pkgconfig(ecore-wayland)
88 %endif
89
90 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
91 BuildRequires:  pkgconfig(libtbm)
92
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 # for dali-adaptor
96 BuildRequires:  pkgconfig(appcore-ui)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for autofill
106 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
107 BuildRequires:  pkgconfig(capi-ui-autofill)
108 %endif
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113
114 # for multiprofile
115 Requires:   %{name}-compat = %{version}-%{release}
116 Recommends: %{name}-profile_common = %{version}-%{release}
117
118 %description
119 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
120 platform abstraction and application shell
121
122 ###########################################
123 # Dali adapter for profiles
124 ###########################################
125
126 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
127 # if mobile || "undefined"
128 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
129 %package profile_mobile
130 Summary:        The DALi Tizen Adaptor for mobile
131 Provides:       %{name}-compat = %{version}-%{release}
132 Conflicts:      %{name}-profile_tv
133 Conflicts:      %{name}-profile_wearable
134 Conflicts:      %{name}-profile_ivi
135 Conflicts:      %{name}-profile_common
136 Requires:       %{name}
137 %description profile_mobile
138 The DALi Tizen Adaptor for mobile.
139 %endif
140
141 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
142 # if tv ||"undefined"
143 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
144 %package profile_tv
145 Summary:        The DALi Tizen Adaptor for tv
146 Provides:       %{name}-compat = %{version}-%{release}
147 Conflicts:      %{name}-profile_mobile
148 Conflicts:      %{name}-profile_wearable
149 Conflicts:      %{name}-profile_ivi
150 Conflicts:      %{name}-profile_common
151 Requires:       %{name}
152 %description profile_tv
153 The DALi Tizen Adaptor for tv.
154 %endif
155
156 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
157 # if wearable || "undefined"
158 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
159 %package profile_wearable
160 Summary:        The DALi Tizen Adaptor for wearable
161 Provides:       %{name}-compat = %{version}-%{release}
162 Conflicts:      %{name}-profile_mobile
163 Conflicts:      %{name}-profile_tv
164 Conflicts:      %{name}-profile_ivi
165 Conflicts:      %{name}-profile_common
166 Requires:       %{name}
167 %description profile_wearable
168 The DALi Tizen Adaptor for wearable.
169 %endif
170
171 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
172 # if ivi ||"undefined"
173 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
174 %package profile_ivi
175 Summary:        The DALi Tizen Adaptor for ivi
176 Provides:       %{name}-compat = %{version}-%{release}
177 Conflicts:      %{name}-profile_mobile
178 Conflicts:      %{name}-profile_wearable
179 Conflicts:      %{name}-profile_tv
180 Conflicts:      %{name}-profile_common
181 Requires:       %{name}
182 %description profile_ivi
183 The DALi Tizen Adaptor for ivi.
184 %endif
185
186 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
187 # if common ||"undefined"
188 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
189 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
190 %package profile_common
191 Summary:        The DALi Tizen Adaptor for common
192 Provides:       %{name}-compat = %{version}-%{release}
193 Conflicts:      %{name}-profile_mobile
194 Conflicts:      %{name}-profile_wearable
195 Conflicts:      %{name}-profile_tv
196 Conflicts:      %{name}-profile_ivi
197 Requires:       %{name}
198 %description profile_common
199 The DALi Tizen Adaptor for common.
200 %endif
201
202 ##############################
203 # devel
204 ##############################
205 %package devel
206 Summary:    Development components for the DALi Tizen Adaptor
207 Group:      Development/Building
208 Requires:   %{name} = %{version}-%{release}
209 Requires:   %{name}-integration-devel = %{version}-%{release}
210
211 %description devel
212 Development components for the DALi Tizen Adaptor - public headers and package configs
213
214 ##############################
215 # integration-devel
216 ##############################
217 %package integration-devel
218 Summary:    Integration development package for the Adaptor
219 Group:      Development/Building
220 Requires:   %{name} = %{version}-%{release}
221
222 %description integration-devel
223 Integration development package for the Adaptor - headers for integrating with an adaptor library.
224
225 ##############################
226 # Dali Feedback Plugin
227 ##############################
228 %package dali-feedback-plugin
229 Summary:    Plugin to play haptic and audio feedback for Dali
230 Group:      System/Libraries
231 Requires:   %{name} = %{version}-%{release}
232 %description dali-feedback-plugin
233 Feedback plugin to play haptic and audio feedback for Dali
234
235 ##############################
236 # Preparation
237 ##############################
238 %prep
239 %setup -q
240
241 #Use TZ_PATH when tizen version is 3.x or greater
242
243 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
244 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
245 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
246 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
247 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
248 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
249
250 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
251 %define dali_plugin_sound_files  /plugins/sounds/
252
253 ##############################
254 # Build
255 ##############################
256 %build
257 PREFIX+="/usr"
258 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
259 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
260
261 %ifarch %{arm}
262 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
263 %endif
264
265 CFLAGS+=" -DWAYLAND"
266 CXXFLAGS+=" -DWAYLAND"
267 cmake_flags=" -DENABLE_WAYLAND=ON"
268
269 # Use this conditional when Tizen version is 5.x or greater
270 %if 0%{?tizen_version_major} >= 5
271 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
272
273 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
274 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
275 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
276 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
277 %endif
278
279 %if 0%{?enable_debug}
280 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
281 %endif
282
283 %if 0%{?enable_trace}
284 cmake_flags+=" -DENABLE_TRACE=ON"
285 %endif
286
287 %if 0%{?enable_appfw}
288 cmake_flags+=" -DUSE_APPFW"
289 %endif
290
291 libtoolize --force
292 cd %{_builddir}/%{name}-%{version}/build/tizen
293
294 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
295 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
296 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
297 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
298 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
299 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
300 %if 0%{?tizen_platform_config_supported}
301 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
302 %endif
303
304 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
305 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
306 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
307 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
308 cmake_flags+=" -DENABLE_TIZEN_MINOR_VERSION=%{tizen_version_minor}"
309 cmake_flags+=" -DENABLE_FEEDBACK=YES"
310 cmake_flags+=" -DENABLE_APPFW=YES"
311
312 # Set up the build via Cmake
313 #######################################################################
314 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
315 # if mobile || "undefined"
316 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
317
318 mkdir mobile
319 pushd mobile
320
321 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
322
323 # Build.
324 make %{?jobs:-j%jobs}
325 popd
326
327 %endif
328
329 #######################################################################
330 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
331 # if tv ||"undefined"
332 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
333
334 mkdir tv
335 pushd tv
336
337 cmake -DENABLE_PROFILE=TV $cmake_flags ..
338
339 # Build.
340 make %{?jobs:-j%jobs}
341 popd
342
343 %endif
344
345 #######################################################################
346 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
347 # if wearable || "undefined"
348 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
349
350 mkdir wearable
351 pushd wearable
352
353 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
354
355 # Build.
356 make %{?jobs:-j%jobs}
357 popd
358
359 %endif
360
361 #######################################################################
362 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
363 # if ivi ||"undefined"
364 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
365
366 mkdir ivi
367 pushd ivi
368
369 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
370
371 # Build.
372 make %{?jobs:-j%jobs}
373 popd
374
375 %endif
376
377 #######################################################################
378 # common
379 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
380 # if common ||"undefined"
381 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
382
383 mkdir common
384 pushd common
385
386 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
387
388 # Build.
389 make %{?jobs:-j%jobs}
390 popd
391
392 %endif
393
394 ##############################
395 # Installation
396 ##############################
397 %install
398 rm -rf %{buildroot}
399
400 pushd %{_builddir}/%{name}-%{version}/build/tizen
401
402 # if mobile || "undefined"
403 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
404 pushd mobile
405 %make_install
406 %if "%{?profile}" != "mobile"
407 pushd  %{buildroot}%{_libdir}
408 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
409 popd
410 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
411 %endif
412 popd
413 %endif
414
415 # if tv ||"undefined"
416 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
417 pushd tv
418 %make_install
419 %if "%{?profile}" != "tv"
420 pushd  %{buildroot}%{_libdir}
421 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
422 popd
423 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
424 %endif
425 popd
426 %endif
427
428 # if wearable || "undefined"
429 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
430 pushd wearable
431 %make_install
432 %if "%{?profile}" != "wearable"
433 pushd  %{buildroot}%{_libdir}
434 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
435 popd
436 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
437 %endif
438 popd
439 %endif
440
441 # if ivi ||"undefined"
442 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
443 pushd ivi
444 %make_install
445 %if "%{?profile}" != "ivi"
446 pushd  %{buildroot}%{_libdir}
447 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
448 popd
449 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
450 %endif
451 popd
452 %endif
453
454 # if common ||"undefined"
455 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
456 pushd common
457 %make_install
458 # No clean so we can gather symbol/size information for the common profile
459 popd
460 %endif
461
462 # Create links to ensure linking with cxx11 library is preserved
463 pushd  %{buildroot}%{_libdir}
464 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
465 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
466 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
467 popd
468
469 # Create a symbolic link in integration-api to preserve legacy repo build
470 pushd %{buildroot}%{_includedir}/dali/integration-api
471 ln -sf adaptor-framework adaptors
472 popd
473
474 ##############################
475 # Upgrade order:
476 # 1 - Pre Install new package
477 # 2 - Install new package
478 # 3 - Post install new package
479 # 4 - Pre uninstall old package
480 # 5 - Remove files not overwritten by new package
481 # 6 - Post uninstall old package
482 ##############################
483
484 ##############################
485 # Adaptor package Commands
486 %pre
487 exit 0
488
489 %post
490 pushd %{_libdir}
491 for i in mobile tv wearable ivi; do [[ -f libdali-adaptor.so.$i ]] && ln -sf libdali-adaptor.so.$i libdali-adaptor.so.0.0.0; done
492 popd
493 /sbin/ldconfig
494 exit 0
495
496 %preun
497 exit 0
498
499 %postun
500 /sbin/ldconfig
501 exit 0
502
503 ##############################
504 # Mobile Profile Commands
505 # if mobile || "undefined"
506 # No need to create a symbolic link on install required if only building this profile
507 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
508 %post profile_mobile
509 %if "%{?profile}" != "mobile"
510 pushd %{_libdir}
511 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
512 popd
513 %endif
514 /sbin/ldconfig
515 exit 0
516
517 %postun profile_mobile
518 /sbin/ldconfig
519 exit 0
520 %endif
521
522 ##############################
523 # TV Profile Commands
524 # No need to create a symbolic link on install required if only building this profile
525 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
526 %post profile_tv
527 %if "%{?profile}" != "tv"
528 pushd %{_libdir}
529 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
530 popd
531 %endif
532 /sbin/ldconfig
533 exit 0
534
535 %postun profile_tv
536 /sbin/ldconfig
537 exit 0
538 %endif
539
540 ##############################
541 # Wearable Profile Commands
542 # No need to create a symbolic link on install required if only building this profile
543 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
544 %post profile_wearable
545 %if "%{?profile}" != "wearable"
546 pushd %{_libdir}
547 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
548 popd
549 %endif
550 /sbin/ldconfig
551 exit 0
552
553 %postun profile_wearable
554 /sbin/ldconfig
555 exit 0
556 %endif
557
558 ##############################
559 # IVI Profile Commands
560 # No need to create a symbolic link on install required if only building this profile
561 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
562 %post profile_ivi
563 %if "%{?profile}" != "ivi"
564 pushd %{_libdir}
565 ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
566 popd
567 %endif
568 /sbin/ldconfig
569 exit 0
570
571 %postun profile_ivi
572 /sbin/ldconfig
573 exit 0
574 %endif
575
576 ##############################
577 # Common Profile Commands
578 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
579 %post profile_common
580 /sbin/ldconfig
581 exit 0
582
583 %postun profile_common
584 /sbin/ldconfig
585 exit 0
586 %endif
587
588 ##############################
589 # Files in Binary Packages
590 ##############################
591
592 %files
593 %manifest dali-adaptor.manifest
594 %defattr(-,root,root,-)
595 %dir %{user_shader_cache_dir}
596 %{_bindir}/*
597 %license LICENSE
598 %defattr(-,root,root,-)
599 %{_libdir}/libdali-adaptor-cxx11.so
600 %{_libdir}/libdali-adaptor-cxx11.so.0
601 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
602 %{_libdir}/libdali-adaptor.so
603 %{_libdir}/libdali-adaptor.so.0
604 %{_libdir}/libdali-adaptor.so.0.0.0
605
606 #################################################
607
608 %files dali-feedback-plugin
609 %manifest dali-adaptor.manifest
610 %defattr(-,root,root,-)
611 %{_libdir}/libdali-feedback-plugin-cxx11.so*
612 %{dali_plugin_sound_files}/*
613
614 #################################################
615
616 # if common ||"undefined"
617 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
618 %files profile_common
619 %manifest dali-adaptor.manifest
620 # default .so files are housed in the main pkg.
621 %endif
622
623 # if mobile || "undefined"
624 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
625 %files profile_mobile
626 %manifest dali-adaptor.manifest
627 %defattr(-,root,root,-)
628 %if "%{?profile}" != "mobile"
629 %{_libdir}/libdali-adaptor.so.mobile
630 %endif
631 %endif
632
633 # if tv ||"undefined"
634 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
635 %files profile_tv
636 %manifest dali-adaptor.manifest
637 %defattr(-,root,root,-)
638 %if "%{?profile}" != "tv"
639 %{_libdir}/libdali-adaptor.so.tv
640 %endif
641 %endif
642
643 # if wearable || "undefined"
644 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
645 %files profile_wearable
646 %manifest dali-adaptor.manifest
647 %defattr(-,root,root,-)
648 %if "%{?profile}" != "wearable"
649 %{_libdir}/libdali-adaptor.so.wearable
650 %endif
651 %endif
652
653 # if ivi ||"undefined"
654 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
655 %files profile_ivi
656 %manifest dali-adaptor.manifest
657 %defattr(-,root,root,-)
658 %if "%{?profile}" != "ivi"
659 %{_libdir}/libdali-adaptor.so.ivi
660 %endif
661 %endif
662
663 %files devel
664 %defattr(-,root,root,-)
665 %{_includedir}/dali/dali.h
666 %{_includedir}/dali/public-api/*
667 %{_includedir}/dali/devel-api/*
668 %{_includedir}/dali/doc/*
669 %{_libdir}/pkgconfig/dali-adaptor.pc
670
671 %files integration-devel
672 %defattr(-,root,root,-)
673 %{_includedir}/dali/integration-api/adaptor-framework/*
674 %{_includedir}/dali/integration-api/adaptors
675 %{_libdir}/pkgconfig/dali-adaptor-integration.pc