5e6a24f3c147410919ba89bb08721f1bd60a2093
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.54
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30 Provides: libdali-adaptor-cxx11.so
31 Provides: libdali-adaptor-cxx11.so.0
32 Provides: libdali-adaptor-cxx11.so.0.0.0
33 Provides: libdali-adaptor.so
34 Provides: libdali-adaptor.so.0
35 Provides: libdali-adaptor.so.0.0.0
36
37 %define tizen_platform_config_supported 1
38 BuildRequires:  pkgconfig(libtzplatform-config)
39
40 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
41 # if wearable || "undefined"
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
43 BuildRequires:  pkgconfig(capi-appfw-watch-application)
44 BuildRequires:  pkgconfig(appcore-watch)
45 BuildRequires:  pkgconfig(screen_connector_provider)
46 %endif
47
48 BuildRequires:  pkgconfig(gles20)
49 BuildRequires:  pkgconfig(glesv2)
50 BuildRequires:  pkgconfig(ttrace)
51
52 BuildRequires:  dali-devel
53 BuildRequires:  dali-integration-devel
54
55 BuildRequires:  pkgconfig
56 BuildRequires:  gawk
57 BuildRequires:  cmake
58 BuildRequires:  giflib-devel
59 BuildRequires:  pkgconfig(fontconfig)
60 BuildRequires:  libjpeg-turbo-devel
61 BuildRequires:  pkgconfig(vconf)
62 BuildRequires:  tts-devel
63 BuildRequires:  pkgconfig(dlog)
64 BuildRequires:  libdrm-devel
65 BuildRequires:  pkgconfig(libexif)
66 BuildRequires:  pkgconfig(libpng)
67 BuildRequires:  pkgconfig(egl)
68 BuildRequires:  libcurl-devel
69 BuildRequires:  pkgconfig(harfbuzz)
70 BuildRequires:  fribidi-devel
71
72 BuildRequires:  pkgconfig(capi-system-info)
73 BuildRequires:  pkgconfig(capi-system-sensor)
74
75 BuildRequires:  pkgconfig(cairo)
76
77 BuildRequires:  pkgconfig(wayland-egl)
78 BuildRequires:  pkgconfig(wayland-client)
79 BuildRequires:  wayland-devel
80 BuildRequires:  wayland-extension-client-devel
81
82 # dali-adaptor uses ecore mainloop
83 %if 0%{?tizen_version_major} >= 5
84 BuildRequires:  pkgconfig(ecore-wl2)
85 BuildRequires:  pkgconfig(wayland-egl-tizen)
86 %else
87 BuildRequires:  pkgconfig(ecore-wayland)
88 %endif
89
90 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
91 BuildRequires:  pkgconfig(libtbm)
92
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 # for dali-adaptor
96 BuildRequires:  pkgconfig(appcore-ui)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for autofill
106 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
107 BuildRequires:  pkgconfig(capi-ui-autofill)
108 %endif
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113
114 # for multiprofile
115 Requires:   %{name}-compat = %{version}-%{release}
116 Recommends: %{name}-profile_common = %{version}-%{release}
117
118 %description
119 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
120 platform abstraction and application shell
121
122 ###########################################
123 # Dali adapter for profiles
124 ###########################################
125
126 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
127 # if mobile || "undefined"
128 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
129 %package profile_mobile
130 Summary:        The DALi Tizen Adaptor for mobile
131 Provides:       %{name}-compat = %{version}-%{release}
132 Conflicts:      %{name}-profile_tv
133 Conflicts:      %{name}-profile_wearable
134 Conflicts:      %{name}-profile_ivi
135 Conflicts:      %{name}-profile_common
136 Requires:       %{name}
137 %description profile_mobile
138 The DALi Tizen Adaptor for mobile.
139 %endif
140
141 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
142 # if tv ||"undefined"
143 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
144 %package profile_tv
145 Summary:        The DALi Tizen Adaptor for tv
146 Provides:       %{name}-compat = %{version}-%{release}
147 Conflicts:      %{name}-profile_mobile
148 Conflicts:      %{name}-profile_wearable
149 Conflicts:      %{name}-profile_ivi
150 Conflicts:      %{name}-profile_common
151 Requires:       %{name}
152 %description profile_tv
153 The DALi Tizen Adaptor for tv.
154 %endif
155
156 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
157 # if wearable || "undefined"
158 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
159 %package profile_wearable
160 Summary:        The DALi Tizen Adaptor for wearable
161 Provides:       %{name}-compat = %{version}-%{release}
162 Conflicts:      %{name}-profile_mobile
163 Conflicts:      %{name}-profile_tv
164 Conflicts:      %{name}-profile_ivi
165 Conflicts:      %{name}-profile_common
166 Requires:       %{name}
167 %description profile_wearable
168 The DALi Tizen Adaptor for wearable.
169 %endif
170
171 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
172 # if ivi ||"undefined"
173 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
174 %package profile_ivi
175 Summary:        The DALi Tizen Adaptor for ivi
176 Provides:       %{name}-compat = %{version}-%{release}
177 Conflicts:      %{name}-profile_mobile
178 Conflicts:      %{name}-profile_wearable
179 Conflicts:      %{name}-profile_tv
180 Conflicts:      %{name}-profile_common
181 Requires:       %{name}
182 %description profile_ivi
183 The DALi Tizen Adaptor for ivi.
184 %endif
185
186 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
187 # if common ||"undefined"
188 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
189 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
190 %package profile_common
191 Summary:        The DALi Tizen Adaptor for common
192 Provides:       %{name}-compat = %{version}-%{release}
193 Conflicts:      %{name}-profile_mobile
194 Conflicts:      %{name}-profile_wearable
195 Conflicts:      %{name}-profile_tv
196 Conflicts:      %{name}-profile_ivi
197 Requires:       %{name}
198 %description profile_common
199 The DALi Tizen Adaptor for common.
200 %endif
201
202 ##############################
203 # devel
204 ##############################
205 %package devel
206 Summary:    Development components for the DALi Tizen Adaptor
207 Group:      Development/Building
208 Requires:   %{name} = %{version}-%{release}
209 Requires:   %{name}-integration-devel = %{version}-%{release}
210
211 %description devel
212 Development components for the DALi Tizen Adaptor - public headers and package configs
213
214 ##############################
215 # integration-devel
216 ##############################
217 %package integration-devel
218 Summary:    Integration development package for the Adaptor
219 Group:      Development/Building
220 Requires:   %{name} = %{version}-%{release}
221
222 %description integration-devel
223 Integration development package for the Adaptor - headers for integrating with an adaptor library.
224
225 ##############################
226 # Dali Feedback Plugin
227 ##############################
228 %package dali-feedback-plugin
229 Summary:    Plugin to play haptic and audio feedback for Dali
230 Group:      System/Libraries
231 Requires:   %{name} = %{version}-%{release}
232 %description dali-feedback-plugin
233 Feedback plugin to play haptic and audio feedback for Dali
234
235 ##############################
236 # Preparation
237 ##############################
238 %prep
239 %setup -q
240
241 #Use TZ_PATH when tizen version is 3.x or greater
242
243 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
244 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
245 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
246 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
247 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
248 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
249
250 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
251 %define dali_plugin_sound_files  /plugins/sounds/
252
253 ##############################
254 # Build
255 ##############################
256 %build
257 PREFIX+="/usr"
258 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
259 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
260
261 %ifarch %{arm}
262 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
263 %endif
264
265 CFLAGS+=" -DWAYLAND"
266 CXXFLAGS+=" -DWAYLAND"
267 cmake_flags=" -DENABLE_WAYLAND=ON"
268
269 # Use this conditional when Tizen version is 5.x or greater
270 %if 0%{?tizen_version_major} >= 5
271 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
272
273 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
274 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
275 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
276 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
277 %endif
278
279 %if 0%{?enable_debug}
280 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
281 %endif
282
283 %if 0%{?enable_trace}
284 cmake_flags+=" -DENABLE_TRACE=ON"
285 %endif
286
287 libtoolize --force
288 cd %{_builddir}/%{name}-%{version}/build/tizen
289
290 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
291 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
292 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
293 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
294 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
295 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
296 %if 0%{?tizen_platform_config_supported}
297 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
298 %endif
299
300 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
301 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
302 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
303 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
304 cmake_flags+=" -DENABLE_TIZEN_MINOR_VERSION=%{tizen_version_minor}"
305 cmake_flags+=" -DENABLE_FEEDBACK=YES"
306 cmake_flags+=" -DENABLE_APPFW=YES"
307
308 # Set up the build via Cmake
309 #######################################################################
310 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
311 # if mobile || "undefined"
312 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
313
314 mkdir mobile
315 pushd mobile
316
317 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
318
319 # Build.
320 make %{?jobs:-j%jobs}
321 popd
322
323 %endif
324
325 #######################################################################
326 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
327 # if tv ||"undefined"
328 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
329
330 mkdir tv
331 pushd tv
332
333 cmake -DENABLE_PROFILE=TV $cmake_flags ..
334
335 # Build.
336 make %{?jobs:-j%jobs}
337 popd
338
339 %endif
340
341 #######################################################################
342 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
343 # if wearable || "undefined"
344 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
345
346 mkdir wearable
347 pushd wearable
348
349 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
350
351 # Build.
352 make %{?jobs:-j%jobs}
353 popd
354
355 %endif
356
357 #######################################################################
358 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
359 # if ivi ||"undefined"
360 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
361
362 mkdir ivi
363 pushd ivi
364
365 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
366
367 # Build.
368 make %{?jobs:-j%jobs}
369 popd
370
371 %endif
372
373 #######################################################################
374 # common
375 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
376 # if common ||"undefined"
377 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
378
379 mkdir common
380 pushd common
381
382 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
383
384 # Build.
385 make %{?jobs:-j%jobs}
386 popd
387
388 %endif
389
390 ##############################
391 # Installation
392 ##############################
393 %install
394 rm -rf %{buildroot}
395
396 pushd %{_builddir}/%{name}-%{version}/build/tizen
397
398 # if mobile || "undefined"
399 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
400 pushd mobile
401 %make_install
402 %if "%{?profile}" != "mobile"
403 pushd  %{buildroot}%{_libdir}
404 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
405 popd
406 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
407 %endif
408 popd
409 %endif
410
411 # if tv ||"undefined"
412 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
413 pushd tv
414 %make_install
415 %if "%{?profile}" != "tv"
416 pushd  %{buildroot}%{_libdir}
417 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
418 popd
419 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
420 %endif
421 popd
422 %endif
423
424 # if wearable || "undefined"
425 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
426 pushd wearable
427 %make_install
428 %if "%{?profile}" != "wearable"
429 pushd  %{buildroot}%{_libdir}
430 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
431 popd
432 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
433 %endif
434 popd
435 %endif
436
437 # if ivi ||"undefined"
438 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
439 pushd ivi
440 %make_install
441 %if "%{?profile}" != "ivi"
442 pushd  %{buildroot}%{_libdir}
443 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
444 popd
445 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
446 %endif
447 popd
448 %endif
449
450 # if common ||"undefined"
451 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
452 pushd common
453 %make_install
454 # No clean so we can gather symbol/size information for the common profile
455 popd
456 %endif
457
458 # Create links to ensure linking with cxx11 library is preserved
459 pushd  %{buildroot}%{_libdir}
460 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
461 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
462 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
463 popd
464
465 # Create a symbolic link in integration-api to preserve legacy repo build
466 pushd %{buildroot}%{_includedir}/dali/integration-api
467 ln -sf adaptor-framework adaptors
468 popd
469
470 ##############################
471 # Upgrade order:
472 # 1 - Pre Install new package
473 # 2 - Install new package
474 # 3 - Post install new package
475 # 4 - Pre uninstall old package
476 # 5 - Remove files not overwritten by new package
477 # 6 - Post uninstall old package
478 ##############################
479
480 ##############################
481 # Adaptor package Commands
482 %pre
483 exit 0
484
485 %post
486 pushd %{_libdir}
487 for i in mobile tv wearable ivi; do [[ -f libdali-adaptor.so.$i ]] && ln -sf libdali-adaptor.so.$i libdali-adaptor.so.0.0.0; done
488 popd
489 /sbin/ldconfig
490 exit 0
491
492 %preun
493 exit 0
494
495 %postun
496 /sbin/ldconfig
497 exit 0
498
499 ##############################
500 # Mobile Profile Commands
501 # if mobile || "undefined"
502 # No need to create a symbolic link on install required if only building this profile
503 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
504 %post profile_mobile
505 %if "%{?profile}" != "mobile"
506 pushd %{_libdir}
507 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
508 popd
509 %endif
510 /sbin/ldconfig
511 exit 0
512
513 %postun profile_mobile
514 /sbin/ldconfig
515 exit 0
516 %endif
517
518 ##############################
519 # TV Profile Commands
520 # No need to create a symbolic link on install required if only building this profile
521 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
522 %post profile_tv
523 %if "%{?profile}" != "tv"
524 pushd %{_libdir}
525 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
526 popd
527 %endif
528 /sbin/ldconfig
529 exit 0
530
531 %postun profile_tv
532 /sbin/ldconfig
533 exit 0
534 %endif
535
536 ##############################
537 # Wearable Profile Commands
538 # No need to create a symbolic link on install required if only building this profile
539 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
540 %post profile_wearable
541 %if "%{?profile}" != "wearable"
542 pushd %{_libdir}
543 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
544 popd
545 %endif
546 /sbin/ldconfig
547 exit 0
548
549 %postun profile_wearable
550 /sbin/ldconfig
551 exit 0
552 %endif
553
554 ##############################
555 # IVI Profile Commands
556 # No need to create a symbolic link on install required if only building this profile
557 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
558 %post profile_ivi
559 %if "%{?profile}" != "ivi"
560 pushd %{_libdir}
561 ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
562 popd
563 %endif
564 /sbin/ldconfig
565 exit 0
566
567 %postun profile_ivi
568 /sbin/ldconfig
569 exit 0
570 %endif
571
572 ##############################
573 # Common Profile Commands
574 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
575 %post profile_common
576 /sbin/ldconfig
577 exit 0
578
579 %postun profile_common
580 /sbin/ldconfig
581 exit 0
582 %endif
583
584 ##############################
585 # Files in Binary Packages
586 ##############################
587
588 %files
589 %manifest dali-adaptor.manifest
590 %defattr(-,root,root,-)
591 %dir %{user_shader_cache_dir}
592 %{_bindir}/*
593 %license LICENSE
594 %defattr(-,root,root,-)
595 %{_libdir}/libdali-adaptor-cxx11.so
596 %{_libdir}/libdali-adaptor-cxx11.so.0
597 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
598 %{_libdir}/libdali-adaptor.so
599 %{_libdir}/libdali-adaptor.so.0
600 %{_libdir}/libdali-adaptor.so.0.0.0
601
602 #################################################
603
604 %files dali-feedback-plugin
605 %manifest dali-adaptor.manifest
606 %defattr(-,root,root,-)
607 %{_libdir}/libdali-feedback-plugin-cxx11.so*
608 %{dali_plugin_sound_files}/*
609
610 #################################################
611
612 # if common ||"undefined"
613 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
614 %files profile_common
615 %manifest dali-adaptor.manifest
616 # default .so files are housed in the main pkg.
617 %endif
618
619 # if mobile || "undefined"
620 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
621 %files profile_mobile
622 %manifest dali-adaptor.manifest
623 %defattr(-,root,root,-)
624 %if "%{?profile}" != "mobile"
625 %{_libdir}/libdali-adaptor.so.mobile
626 %endif
627 %endif
628
629 # if tv ||"undefined"
630 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
631 %files profile_tv
632 %manifest dali-adaptor.manifest
633 %defattr(-,root,root,-)
634 %if "%{?profile}" != "tv"
635 %{_libdir}/libdali-adaptor.so.tv
636 %endif
637 %endif
638
639 # if wearable || "undefined"
640 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
641 %files profile_wearable
642 %manifest dali-adaptor.manifest
643 %defattr(-,root,root,-)
644 %if "%{?profile}" != "wearable"
645 %{_libdir}/libdali-adaptor.so.wearable
646 %endif
647 %endif
648
649 # if ivi ||"undefined"
650 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
651 %files profile_ivi
652 %manifest dali-adaptor.manifest
653 %defattr(-,root,root,-)
654 %if "%{?profile}" != "ivi"
655 %{_libdir}/libdali-adaptor.so.ivi
656 %endif
657 %endif
658
659 %files devel
660 %defattr(-,root,root,-)
661 %{_includedir}/dali/dali.h
662 %{_includedir}/dali/public-api/*
663 %{_includedir}/dali/devel-api/*
664 %{_includedir}/dali/doc/*
665 %{_libdir}/pkgconfig/dali-adaptor.pc
666
667 %files integration-devel
668 %defattr(-,root,root,-)
669 %{_includedir}/dali/integration-api/adaptor-framework/*
670 %{_includedir}/dali/integration-api/adaptors
671 %{_libdir}/pkgconfig/dali-adaptor-integration.pc