Merge branch 'new_text' into tizen
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor-tv.spec
1 Name:       dali-adaptor
2 Summary:    The DALi Tizen Adaptor
3 Version:    1.0.36
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
8 Source0:    %{name}-%{version}.tar.gz
9
10 %define dali_feedback_plugin 0
11 %define dali_bullet_plugin 0
12 %define dali_assimp_plugin 0
13
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 Requires:       boost-thread
17 Requires:       giflib
18 BuildRequires:  pkgconfig
19 BuildRequires:  gawk
20 BuildRequires:  pkgconfig(sensor)
21 BuildRequires:  pkgconfig(aul)
22 BuildRequires:  boost-devel
23 BuildRequires:  giflib-devel
24 BuildRequires:  pkgconfig(fontconfig)
25 BuildRequires:  pkgconfig(elementary)
26 BuildRequires:  pkgconfig(capi-appfw-application)
27 BuildRequires:  libjpeg-turbo-devel
28 BuildRequires:  pkgconfig(evas)
29 BuildRequires:  dali-devel
30 BuildRequires:  dali-integration-devel
31 BuildRequires:  libxml2-devel
32 BuildRequires:  pkgconfig(vconf)
33 BuildRequires:  tts-devel
34 BuildRequires:  pkgconfig(dlog)
35 BuildRequires:  libdrm-devel
36 BuildRequires:  pkgconfig(libexif)
37 BuildRequires:  pkgconfig(capi-system-system-settings)
38 BuildRequires:  pkgconfig(libpng)
39 BuildRequires:  pkgconfig(xi)
40 BuildRequires:  pkgconfig(xfixes)
41 BuildRequires:  pkgconfig(xdamage)
42 BuildRequires:  pkgconfig(utilX)
43 BuildRequires:  pkgconfig(gles20)
44 BuildRequires:  libcurl-devel
45 BuildRequires:  pkgconfig(harfbuzz)
46 BuildRequires:  fribidi-devel
47
48 %if 0%{?dali_assimp_plugin}
49 BuildRequires:  pkgconfig(assimp)
50 %endif
51
52 %description
53 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
54 platform abstraction and application shell
55
56 ##############################
57 # devel
58 ##############################
59 %package devel
60 Summary:    Development components for the DALi Tizen Adaptor
61 Group:      Development/Building
62 Requires:   %{name} = %{version}-%{release}
63
64 %description devel
65 Development components for the DALi Tizen Adaptor - public headers and package configs
66
67 ##############################
68 # Dali Feedback Plugin
69 ##############################
70 %package dali-feedback-plugin
71 Summary:    Plugin to play haptic and audio feedback for Dali
72 Group:      System/Libraries
73 %if 0%{?dali_feedback_plugin}
74 #Requires:       libdeviced
75 BuildRequires:  pkgconfig(mm-sound)
76 BuildRequires:  pkgconfig(haptic)
77 BuildRequires:  libfeedback-devel
78 %endif
79
80 %description dali-feedback-plugin
81 Feedback plugin to play haptic and audio feedback for Dali
82
83 ##############################
84 # Dali Dynamics/Bullet Plugin
85 ##############################
86 %package dali-bullet-plugin
87 Summary:    Plugin to provide physics
88 Group:      System/Libraries
89 %if 0%{?dali_bullet_plugin}
90 BuildRequires:  pkgconfig(bullet)
91 %endif
92
93 %description dali-bullet-plugin
94 Dynamics plugin to wrap the libBulletDynamics libraries
95
96 ##############################
97 # Preparation
98 ##############################
99 %prep
100 %setup -q
101 %define dali_data_rw_dir         /usr/share/dali/
102 %define dali_data_ro_dir         /usr/share/dali/
103 %define user_font_cache_dir      %{dali_data_rw_dir}/glyphcache/
104 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
105 %define font_preloaded_path      /usr/share/fonts/
106 %define font_downloaded_path     /opt/share/fonts/
107 %define font_application_path    /usr/share/app_fonts/
108 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
109 %define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
110 %define dali_plugin_theme_files  %{dali_data_ro_dir}/themes/feedback-themes/
111
112 %define dev_include_path %{_includedir}
113
114 ##############################
115 # Build
116 ##############################
117 %build
118 PREFIX+="/usr"
119 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
120 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
121
122 %ifarch %{arm}
123 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
124 %endif
125
126 libtoolize --force
127 cd %{_builddir}/%{name}-%{version}/build/tizen
128 autoreconf --install
129 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
130 DALI_DATA_RO_DIR="%{dali_data_ro_dir}" ; export DALI_DATA_RO_DIR
131 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
132 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
133 FONT_APPLICATION_PATH="%{font_application_path}" ; export FONT_APPLICATION_PATH
134 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
135
136 %configure --with-jpeg-turbo --enable-gles=20 --enable-profile=TV \
137 %if 0%{?dali_feedback_plugin}
138            --enable-feedback \
139 %endif
140 %if 0%{?dali_bullet_plugin}
141            --enable-bullet \
142 %endif
143 %if 0%{?dali_assimp_plugin}
144            --enable-assimp \
145 %endif
146            --libdir=%{_libdir}
147
148 make %{?jobs:-j%jobs}
149
150 ##############################
151 # Installation
152 ##############################
153 %install
154 rm -rf %{buildroot}
155 cd build/tizen
156 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
157
158 # LICENSE
159 mkdir -p %{buildroot}/usr/share/license
160 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
161
162 ##############################
163 # Upgrade order:
164 # 1 - Pre Install new package
165 # 2 - Install new package
166 # 3 - Post install new package
167 # 4 - Pre uninstall old package
168 # 5 - Remove files not overwritten by new package
169 # 6 - Post uninstall old package
170 ##############################
171
172 %pre
173 rm -f %{user_font_cache_dir}/*
174 exit 0
175
176 ##############################
177 #  Post Install new package
178 ##############################
179 %post
180 /sbin/ldconfig
181 chown 5000:5000 %{user_font_cache_dir}
182 exit 0
183
184 %if 0%{?dali_feedback_plugin}
185 %post dali-feedback-plugin
186 /sbin/ldconfig
187 exit 0
188 %endif
189
190 %if 0%{?dali_bullet_plugin}
191 %post dali-bullet-plugin
192 /sbin/ldconfig
193 exit 0
194 %endif
195
196 ##############################
197 #   Pre Uninstall old package
198 ##############################
199 %preun
200 rm -f %{user_font_cache_dir}/*
201 exit 0
202
203 ##############################
204 #   Post Uninstall old package
205 ##############################
206 %postun
207 /sbin/ldconfig
208 exit 0
209
210 %if 0%{?dali_feedback_plugin}
211 %postun dali-feedback-plugin
212 /sbin/ldconfig
213 exit 0
214 %endif
215
216 %if 0%{?dali_bullet_plugin}
217 %postun dali-bullet-plugin
218 /sbin/ldconfig
219 exit 0
220 %endif
221
222
223 ##############################
224 # Files in Binary Packages
225 ##############################
226
227 %files
228 %manifest dali-adaptor.manifest-tv
229 %defattr(-,root,root,-)
230 %{_libdir}/libdali-adap*.so*
231 %defattr(-,app,app,-)
232 %dir %{user_font_cache_dir}
233 %dir %{user_shader_cache_dir}
234 %{_bindir}/*
235 %{_datadir}/license/%{name}
236
237 %files devel
238 %defattr(-,root,root,-)
239 %{dev_include_path}/dali/*
240 %{_libdir}/pkgconfig/dali*.pc
241
242 %if 0%{?dali_feedback_plugin}
243 %files dali-feedback-plugin
244 %defattr(-,root,root,-)
245 %{_libdir}/libdali-feedback-plugin.so*
246 %{dali_plugin_sound_files}/*
247 %{dali_plugin_theme_files}/*
248 %endif
249
250 %if 0%{?dali_bullet_plugin}
251 %files dali-bullet-plugin
252 %defattr(-,root,root,-)
253 %{_libdir}/libdali-bullet-plugin.so*
254 %endif