Merge "Remove RenderThread::mSurface pointer before mWindow.Reset()" into devel/master
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor-tv.spec
1 Name:       dali-adaptor
2 Summary:    The DALi Tizen Adaptor
3 Version:    1.0.51
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
8 Source0:    %{name}-%{version}.tar.gz
9
10 %define dali_feedback_plugin 0
11 %define dali_bullet_plugin 0
12 %define dali_assimp_plugin 0
13
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 Requires:       boost-thread
17 Requires:       giflib
18 BuildRequires:  pkgconfig
19 BuildRequires:  gawk
20 BuildRequires:  pkgconfig(sensor)
21 BuildRequires:  pkgconfig(aul)
22 BuildRequires:  boost-devel
23 BuildRequires:  giflib-devel
24 BuildRequires:  pkgconfig(fontconfig)
25 BuildRequires:  pkgconfig(elementary)
26 BuildRequires:  pkgconfig(capi-appfw-application)
27 BuildRequires:  libjpeg-turbo-devel
28 BuildRequires:  pkgconfig(evas)
29 BuildRequires:  dali-devel
30 BuildRequires:  dali-integration-devel
31 BuildRequires:  libxml2-devel
32 BuildRequires:  pkgconfig(vconf)
33 BuildRequires:  tts-devel
34 BuildRequires:  pkgconfig(dlog)
35 BuildRequires:  libdrm-devel
36 BuildRequires:  pkgconfig(libexif)
37 BuildRequires:  pkgconfig(capi-system-system-settings)
38 BuildRequires:  pkgconfig(libpng)
39 BuildRequires:  pkgconfig(xi)
40 BuildRequires:  pkgconfig(xfixes)
41 BuildRequires:  pkgconfig(xdamage)
42 BuildRequires:  pkgconfig(utilX)
43 BuildRequires:  pkgconfig(gles20)
44 BuildRequires:  libcurl-devel
45 BuildRequires:  pkgconfig(harfbuzz)
46 BuildRequires:  fribidi-devel
47
48 %if 0%{?dali_assimp_plugin}
49 BuildRequires:  pkgconfig(assimp)
50 %endif
51
52 %description
53 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
54 platform abstraction and application shell
55
56 ##############################
57 # devel
58 ##############################
59 %package devel
60 Summary:    Development components for the DALi Tizen Adaptor
61 Group:      Development/Building
62 Requires:   %{name} = %{version}-%{release}
63 Requires:   boost-devel
64
65 %description devel
66 Development components for the DALi Tizen Adaptor - public headers and package configs
67
68 ##############################
69 # Dali Feedback Plugin
70 ##############################
71 %package dali-feedback-plugin
72 Summary:    Plugin to play haptic and audio feedback for Dali
73 Group:      System/Libraries
74 %if 0%{?dali_feedback_plugin}
75 #Requires:       libdeviced
76 BuildRequires:  pkgconfig(mm-sound)
77 BuildRequires:  pkgconfig(haptic)
78 BuildRequires:  libfeedback-devel
79 %endif
80
81 %description dali-feedback-plugin
82 Feedback plugin to play haptic and audio feedback for Dali
83
84 ##############################
85 # Dali Dynamics/Bullet Plugin
86 ##############################
87 %package dali-bullet-plugin
88 Summary:    Plugin to provide physics
89 Group:      System/Libraries
90 %if 0%{?dali_bullet_plugin}
91 BuildRequires:  pkgconfig(bullet)
92 %endif
93
94 %description dali-bullet-plugin
95 Dynamics plugin to wrap the libBulletDynamics libraries
96
97 ##############################
98 # Preparation
99 ##############################
100 %prep
101 %setup -q
102 %define dali_data_rw_dir         /usr/share/dali/
103 %define dali_data_ro_dir         /usr/share/dali/
104 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
105 %define font_preloaded_path      /usr/share/fonts/
106 %define font_downloaded_path     /opt/share/fonts/
107 %define font_application_path    /usr/share/app_fonts/
108 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
109 %define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
110 %define dali_plugin_theme_files  %{dali_data_ro_dir}/themes/feedback-themes/
111
112 %define dev_include_path %{_includedir}
113
114 ##############################
115 # Build
116 ##############################
117 %build
118 PREFIX+="/usr"
119 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
120 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
121
122 %ifarch %{arm}
123 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
124 %endif
125
126 libtoolize --force
127 cd %{_builddir}/%{name}-%{version}/build/tizen
128 autoreconf --install
129 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
130 DALI_DATA_RO_DIR="%{dali_data_ro_dir}" ; export DALI_DATA_RO_DIR
131 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
132 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
133 FONT_APPLICATION_PATH="%{font_application_path}" ; export FONT_APPLICATION_PATH
134 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
135
136 %configure --with-jpeg-turbo --enable-gles=20 --enable-profile=TV \
137 %if 0%{?dali_feedback_plugin}
138            --enable-feedback \
139 %endif
140 %if 0%{?dali_bullet_plugin}
141            --enable-bullet \
142 %endif
143 %if 0%{?dali_assimp_plugin}
144            --enable-assimp \
145 %endif
146            --libdir=%{_libdir}
147
148 make %{?jobs:-j%jobs}
149
150 ##############################
151 # Installation
152 ##############################
153 %install
154 rm -rf %{buildroot}
155 cd build/tizen
156 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
157
158 # LICENSE
159 mkdir -p %{buildroot}/usr/share/license
160 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
161
162 ##############################
163 # Upgrade order:
164 # 1 - Pre Install new package
165 # 2 - Install new package
166 # 3 - Post install new package
167 # 4 - Pre uninstall old package
168 # 5 - Remove files not overwritten by new package
169 # 6 - Post uninstall old package
170 ##############################
171
172 %pre
173 exit 0
174
175 ##############################
176 #  Post Install new package
177 ##############################
178 %post
179 /sbin/ldconfig
180 exit 0
181
182 %if 0%{?dali_feedback_plugin}
183 %post dali-feedback-plugin
184 /sbin/ldconfig
185 exit 0
186 %endif
187
188 %if 0%{?dali_bullet_plugin}
189 %post dali-bullet-plugin
190 /sbin/ldconfig
191 exit 0
192 %endif
193
194 ##############################
195 #   Pre Uninstall old package
196 ##############################
197 %preun
198 exit 0
199
200 ##############################
201 #   Post Uninstall old package
202 ##############################
203 %postun
204 /sbin/ldconfig
205 exit 0
206
207 %if 0%{?dali_feedback_plugin}
208 %postun dali-feedback-plugin
209 /sbin/ldconfig
210 exit 0
211 %endif
212
213 %if 0%{?dali_bullet_plugin}
214 %postun dali-bullet-plugin
215 /sbin/ldconfig
216 exit 0
217 %endif
218
219
220 ##############################
221 # Files in Binary Packages
222 ##############################
223
224 %files
225 %manifest dali-adaptor.manifest-tv
226 %defattr(-,root,root,-)
227 %{_libdir}/libdali-adap*.so*
228 %defattr(-,app,app,-)
229 %dir %{user_shader_cache_dir}
230 %{_bindir}/*
231 %{_datadir}/license/%{name}
232
233 %files devel
234 %defattr(-,root,root,-)
235 %{dev_include_path}/dali/*
236 %{_libdir}/pkgconfig/dali*.pc
237
238 %if 0%{?dali_feedback_plugin}
239 %files dali-feedback-plugin
240 %defattr(-,root,root,-)
241 %{_libdir}/libdali-feedback-plugin.so*
242 %{dali_plugin_sound_files}/*
243 %{dali_plugin_theme_files}/*
244 %endif
245
246 %if 0%{?dali_bullet_plugin}
247 %files dali-bullet-plugin
248 %defattr(-,root,root,-)
249 %{_libdir}/libdali-bullet-plugin.so*
250 %endif