Removed remaining references to glyph cache
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor-tv.spec
1 Name:       dali-adaptor
2 Summary:    The DALi Tizen Adaptor
3 Version:    1.0.41
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
8 Source0:    %{name}-%{version}.tar.gz
9
10 %define dali_feedback_plugin 0
11 %define dali_bullet_plugin 0
12 %define dali_assimp_plugin 0
13
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 Requires:       boost-thread
17 Requires:       giflib
18 BuildRequires:  pkgconfig
19 BuildRequires:  gawk
20 BuildRequires:  pkgconfig(sensor)
21 BuildRequires:  pkgconfig(aul)
22 BuildRequires:  boost-devel
23 BuildRequires:  giflib-devel
24 BuildRequires:  pkgconfig(fontconfig)
25 BuildRequires:  pkgconfig(elementary)
26 BuildRequires:  pkgconfig(capi-appfw-application)
27 BuildRequires:  libjpeg-turbo-devel
28 BuildRequires:  pkgconfig(evas)
29 BuildRequires:  dali-devel
30 BuildRequires:  dali-integration-devel
31 BuildRequires:  libxml2-devel
32 BuildRequires:  pkgconfig(vconf)
33 BuildRequires:  tts-devel
34 BuildRequires:  pkgconfig(dlog)
35 BuildRequires:  libdrm-devel
36 BuildRequires:  pkgconfig(libexif)
37 BuildRequires:  pkgconfig(capi-system-system-settings)
38 BuildRequires:  pkgconfig(libpng)
39 BuildRequires:  pkgconfig(xi)
40 BuildRequires:  pkgconfig(xfixes)
41 BuildRequires:  pkgconfig(xdamage)
42 BuildRequires:  pkgconfig(utilX)
43 BuildRequires:  pkgconfig(gles20)
44 BuildRequires:  libcurl-devel
45 BuildRequires:  pkgconfig(harfbuzz)
46 BuildRequires:  fribidi-devel
47
48 %if 0%{?dali_assimp_plugin}
49 BuildRequires:  pkgconfig(assimp)
50 %endif
51
52 %description
53 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
54 platform abstraction and application shell
55
56 ##############################
57 # devel
58 ##############################
59 %package devel
60 Summary:    Development components for the DALi Tizen Adaptor
61 Group:      Development/Building
62 Requires:   %{name} = %{version}-%{release}
63
64 %description devel
65 Development components for the DALi Tizen Adaptor - public headers and package configs
66
67 ##############################
68 # Dali Feedback Plugin
69 ##############################
70 %package dali-feedback-plugin
71 Summary:    Plugin to play haptic and audio feedback for Dali
72 Group:      System/Libraries
73 %if 0%{?dali_feedback_plugin}
74 #Requires:       libdeviced
75 BuildRequires:  pkgconfig(mm-sound)
76 BuildRequires:  pkgconfig(haptic)
77 BuildRequires:  libfeedback-devel
78 %endif
79
80 %description dali-feedback-plugin
81 Feedback plugin to play haptic and audio feedback for Dali
82
83 ##############################
84 # Dali Dynamics/Bullet Plugin
85 ##############################
86 %package dali-bullet-plugin
87 Summary:    Plugin to provide physics
88 Group:      System/Libraries
89 %if 0%{?dali_bullet_plugin}
90 BuildRequires:  pkgconfig(bullet)
91 %endif
92
93 %description dali-bullet-plugin
94 Dynamics plugin to wrap the libBulletDynamics libraries
95
96 ##############################
97 # Preparation
98 ##############################
99 %prep
100 %setup -q
101 %define dali_data_rw_dir         /usr/share/dali/
102 %define dali_data_ro_dir         /usr/share/dali/
103 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
104 %define font_preloaded_path      /usr/share/fonts/
105 %define font_downloaded_path     /opt/share/fonts/
106 %define font_application_path    /usr/share/app_fonts/
107 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
108 %define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
109 %define dali_plugin_theme_files  %{dali_data_ro_dir}/themes/feedback-themes/
110
111 %define dev_include_path %{_includedir}
112
113 ##############################
114 # Build
115 ##############################
116 %build
117 PREFIX+="/usr"
118 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
119 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
120
121 %ifarch %{arm}
122 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
123 %endif
124
125 libtoolize --force
126 cd %{_builddir}/%{name}-%{version}/build/tizen
127 autoreconf --install
128 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
129 DALI_DATA_RO_DIR="%{dali_data_ro_dir}" ; export DALI_DATA_RO_DIR
130 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
131 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
132 FONT_APPLICATION_PATH="%{font_application_path}" ; export FONT_APPLICATION_PATH
133 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
134
135 %configure --with-jpeg-turbo --enable-gles=20 --enable-profile=TV \
136 %if 0%{?dali_feedback_plugin}
137            --enable-feedback \
138 %endif
139 %if 0%{?dali_bullet_plugin}
140            --enable-bullet \
141 %endif
142 %if 0%{?dali_assimp_plugin}
143            --enable-assimp \
144 %endif
145            --libdir=%{_libdir}
146
147 make %{?jobs:-j%jobs}
148
149 ##############################
150 # Installation
151 ##############################
152 %install
153 rm -rf %{buildroot}
154 cd build/tizen
155 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
156
157 # LICENSE
158 mkdir -p %{buildroot}/usr/share/license
159 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
160
161 ##############################
162 # Upgrade order:
163 # 1 - Pre Install new package
164 # 2 - Install new package
165 # 3 - Post install new package
166 # 4 - Pre uninstall old package
167 # 5 - Remove files not overwritten by new package
168 # 6 - Post uninstall old package
169 ##############################
170
171 %pre
172 exit 0
173
174 ##############################
175 #  Post Install new package
176 ##############################
177 %post
178 /sbin/ldconfig
179 exit 0
180
181 %if 0%{?dali_feedback_plugin}
182 %post dali-feedback-plugin
183 /sbin/ldconfig
184 exit 0
185 %endif
186
187 %if 0%{?dali_bullet_plugin}
188 %post dali-bullet-plugin
189 /sbin/ldconfig
190 exit 0
191 %endif
192
193 ##############################
194 #   Pre Uninstall old package
195 ##############################
196 %preun
197 exit 0
198
199 ##############################
200 #   Post Uninstall old package
201 ##############################
202 %postun
203 /sbin/ldconfig
204 exit 0
205
206 %if 0%{?dali_feedback_plugin}
207 %postun dali-feedback-plugin
208 /sbin/ldconfig
209 exit 0
210 %endif
211
212 %if 0%{?dali_bullet_plugin}
213 %postun dali-bullet-plugin
214 /sbin/ldconfig
215 exit 0
216 %endif
217
218
219 ##############################
220 # Files in Binary Packages
221 ##############################
222
223 %files
224 %manifest dali-adaptor.manifest-tv
225 %defattr(-,root,root,-)
226 %{_libdir}/libdali-adap*.so*
227 %defattr(-,app,app,-)
228 %dir %{user_shader_cache_dir}
229 %{_bindir}/*
230 %{_datadir}/license/%{name}
231
232 %files devel
233 %defattr(-,root,root,-)
234 %{dev_include_path}/dali/*
235 %{_libdir}/pkgconfig/dali*.pc
236
237 %if 0%{?dali_feedback_plugin}
238 %files dali-feedback-plugin
239 %defattr(-,root,root,-)
240 %{_libdir}/libdali-feedback-plugin.so*
241 %{dali_plugin_sound_files}/*
242 %{dali_plugin_theme_files}/*
243 %endif
244
245 %if 0%{?dali_bullet_plugin}
246 %files dali-bullet-plugin
247 %defattr(-,root,root,-)
248 %{_libdir}/libdali-bullet-plugin.so*
249 %endif