Update latest code of platform version 2.4
[platform/upstream/csr-framework.git] / packaging / csr-framework.spec
1 %define csr_test_build 0
2
3 Name: csr-framework
4 Summary: A general purpose content screening and reputation solution
5 Version: 1.1.0
6 Release: 2
7 Group: System/Libraries
8 License: BSD-2.0
9 URL: http://tizen.org
10 Source0: %{name}-%{version}.tar.gz
11 Source1001: %{name}.manifest
12 BuildRequires: cmake
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(libtzplatform-config)
15
16 %description
17 csr-framework
18
19 %package devel
20 Summary:    Development files for csr-framework
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25 csr-framework (development files)
26
27 %if 0%{?csr_test_build}
28 %package test
29 Summary:    test program for csr-framework
30 Group:      Security/Testing
31 Requires:   %{name} = %{version}-%{release}
32
33 %description test
34 Comaptilibty test program
35 %endif
36
37
38 %prep
39 %setup -q
40 cp -a %SOURCE1001 .
41
42
43 %build
44 %{!?build_type:%define build_type "Release"}
45 %cmake . \
46     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
47     -DINCLUDEDIR=%{_includedir}/csf \
48     -DCMAKE_BUILD_TYPE=%build_type \
49 %if 0%{?csr_test_build}
50     -DCSR_TEST_BUILD=1 \
51 %endif
52     -DVERSION=%{version}
53
54 make %{?_smp_mflags}
55
56 %install
57 %make_install
58
59 %post -p /sbin/ldconfig
60 %postun -p /sbin/ldconfig
61
62
63 %files
64 %manifest %name.manifest
65 %license LICENSE
66 %{_libdir}/libsecfw.so.*
67
68 %files devel
69 %doc README
70 %doc doc/
71 %{_includedir}/csf/TCSErrorCodes.h
72 %{_includedir}/csf/TCSImpl.h
73 %{_includedir}/csf/TWPImpl.h
74 %{_libdir}/pkgconfig/*.pc
75 %{_libdir}/libsecfw.so
76
77 %if 0%{?csr_test_build}
78 %files test
79 %{_bindir}/*
80 %endif